Netlify times out when trying to import a project from Github

Hello, I’m trying to deploy a project from a GitHub repo, but I can’t even get to the step to select a repo. When I choose to import an existing project, Netlify hangs on the authentication screen until I get the GitHub unicorn timeout page.

I think the authentication is working okay because I can see it as an authorized app from my GitHub account, but it just stalls at this page until it gives up.

I’ve tried revoking access on GitHub and reauthorizing it, recreated my account both using GitHub Oath and a standard email login, used different browsers (Edge, Chrome, and Firefox), disabled all my extensions, and tried connecting with and without a VPN. I’ve spent a long time searching through the forums and Google, but if people are having this issue, then I haven’t been able to find it.

When I use Chrome’s developer console, it shows me a 502 error after being redirected to the unicorn page (which is at Sign in to GitHub · GitHub for me after a redirect from https://api.netlify.com). Firefox’s console doesn’t show me the 502 error but instead just warns me about cross site tokens. I don’t get any other errors during this process.

I am able to deploy a site by uploading the files, but I haven’t tried connecting to repos on any of the other websites since I don’t use any of them and would prefer not to have to set up an account just to test this.

1 Like

Hi @reallemon,

Could you privately share a HAR file of this issue to either m, @luke, @hillary, or @gualter.

Are you sure that’s the correct file you’ve shared? It doesn’t seem to have any 502 or failed requests.

I’m not positive. The one I shared was from the tab where I launched the import window. I’ll grab one and send it from the popup window as well, but that one doesn’t seem to have any network activity going on in the network tab.

Oh wait, I caught the error in there now. I’ll send the updated one

Based on the HAR file you’ve shared, the time out seems to originate from GitHub’s end. It’s happening on: https://github.com/apps/netlify/installations/new URL, and also has. x-github-request-id header on it - indicating that the page has been served by GitHub.

I think, you might need to contact GitHub to ask why they’re sending a timed out response for that request.

I contacted Github support and resolved the issue. For anyone else who is experiencing the same issue, the problem turned out to be that I was a contributor to an organization with a large number of repositories (me50 in my case). Removing myself as a collaborator fixed the issue and I’m now able to import repositories to Netlify normally.

3 Likes

Thanks for coming back and letting us know-- this will definitely be helpful for future forums members.

Glad this is resolved now.

I revoked the permission to all apps. But the problem persists.

Hey there, @cesaranzola :wave:

Thanks for reaching out. Can you please describe the problem you are encountering with a few more details? Additionally, can you share your netlify account ID and a link to the repository you are having issues with?

Thanks

Hello Hillary, I also have the same problem, please check my link here Cannot connect github repository, which I was talking with Hrishikesh Kokate, telling him the same problem and my replies, the problem is not with one repository, the problem is cannot connect the two accounts Netlify with Github. Thanks for your support!

No need to post your identical question in multiple threads, @Mussino . It slows us down in helping you, so let’s stick to the other thread where I just gave you guidance as to next steps :slight_smile:

ok thanks and sorry for that!