Netlify serve old cached version


I’m using Netlify services since couple month and I love It.

Unfortunetly, since 2 weeks or so, I start to get trouble.

Building is ok.
Deployment is ok.

My react.js application that is serving to browser is actually an old version of files and I can’t figure out why.
I tried anything : custom command build, cleaning cache, manual deploy…

Please help me to go trought this, we have customer on this production app.

Thanks a lot !

Hi, @matcham, we would be happy to troubleshoot this issue. Would you please share with us an example of a URL which is serving out of date content?

HI @luke,

I am facing the above problem as well. Please check out my site at I am getting around this issue by deleting old sites and creating new ones everytime I face the issue.

Wai Chung

hmm, @waichung - i am unable to load that site. Can you verify that is the correct URL?

@perry I’m facing this issue right now, would you mind help me after those months? :slight_smile:

This link is serving a page from Mon, 13 Jul 2020 23:28:22 GMT

Hey @kkfuri,

I can see that we are serving different content across nodes. There appears to be a very small blast radius for this (sub-10% of nodes are serving the incorrect data). I’ve escalated this and we’ll get back to you with next steps :+1:. Thanks for reporting this!

Hey @kkfuri,

Whoops! My bad, looks like a problem with my tooling rather than a cache issue – for now!

Is there any chance I can ask you to download the site and check that you’ve got the right file deployed? Once we confirm this and the file in the deploy is the one you’re trying to serve, we’ll need the x-nf-request-id for a request where you’re being served the wrong data, please!

@Scott, thanks for your attention and quick response;

I will try to download the deployed site asap, for now, a x-nf-request-id that is failing:

x-nf-request-id: 5aebd7e7-49ec-495a-8748-e24271eb5e9b-11857070

Hey! Yeah, that’s interesting. That’s showing the correct deploy ID for the latest published iteration of the site so I’m inclined to think that you haven’t deployed/publish a later version :+1:.

Hey @Scott! @kkfuri and I are working on the same instance.

Here’s a “working” request:

x-nf-request-id: 003dbbe1-cbdb-4835-8c30-6b07f16bfe5a-400833

This is in line with our latest deploy and it’s working for me in Europe.

Here’s a request that is being served by an old function:

x-nf-request-id: b7008fef-c3a0-473b-a9db-bee92e7e428e-12673364

Also, when I click on the download link in Netlify, I get an error message saying “Error during download”. Strangely a file is missing? I’m getting two 404’s.

What should I do?

We have our platform team investigating this and we’ll be sure to provide feedback once we hear more!

In the meantime, we’ve cleared the cache for the impacted nodes; does the problem persist?

@Scott, it does persist.

example post
Serving from Mon, 13 Jul 2020 21:50:49 GMT with this x-nf-request-id: 5a1c16ff-7b14-4b26-8ab3-dd9092c7f519-3558113

No @Scott, unfortunately not :frowning:

We have a stray deploy lurking in some of the nodes apparently :frowning: It’s not running the proper function, too.

Anything we can do on our end to help solve this?


Hijacking this thread, because I think I’m facing the same problem.

  • All seems fine for a long time, all tests, performance, etc… works fine. Deploying a new master is immediate. All is fine. Apparently.
  • I installed “analytics” and saw that I have in the last 24h a lot of 404 for “old resources”.
  • By old, I mean mainly old fingerprint for css/js resources (I use and fingerprinting all my assets).

example (those are old resources from previous build but no more in my code for some time).
And it is not 1 request (as one guy didn’t refresh his page) but several

Resource not found|Requests

  • /css/style.min.758738a9699bfa2e895044200ac627018385d842bb123b841b7eb874319b76ac.css|3
  • /js/concat_main_scripts.min.0902b40c8f9386bc69c1e357d838ca237b8b5bdfcdf9c919c3a2912caa6b142a99aaf64bd5a58c996b3740b51a1c372e.js|3
  • /images/camping/camping-drone-publish3_hub6185e14f48b22b13ba700f86a5af0c4_589341_1157x770_fill_q75_box_smart1.jpg|2
  • /images/arolla/arolla1_hu6ad202c878ea9c1bdf0a71b404f17d9c_406035_1157x770_fill_q50_box_smart1.jpg|2

Etc …

This is my netlify.toml. Thanks for any light/tip

  for = "/images/*"
    Cache-Control = "public, max-age=604800, s-maxage=604800"
  for = "/*.jpg"
    Cache-Control = "public, max-age=604800, s-maxage=604800"
  for = "/*.png"
    Cache-Control = "public, max-age=604800, s-maxage=604800"
  for = "/*.gif"
    Cache-Control = "public, max-age=604800, s-maxage=604800"
  for = "/*.css"
    Cache-Control = "public, max-age=604800, s-maxage=604800"
  for = "/*.js"
    Cache-Control = "public, max-age=604800, s-maxage=604800"
  for = "/fonts/*"
    Cache-Control = "public, max-age=604800, s-maxage=604800"

  package = "netlify-plugin-hugo-cache-resources"

    # If it should show more verbose logs (optional, default = true)
    debug = true

Hey @tcp, @kkfuri, I don’t believe there’s anything do be done at your end but it’s nice to know that you’re proactive and available to help if the team need to ask any Qs! Rest assured, it’s an anomaly which the team are actively working in to.

@divinerites, I’ve checked your site and I can see that we’re serving the same deployed content across all CDN nodes. I’d be tempted to ensure that your headers aren’t caching anything they oughtn’t. Could your issue be something like this? If your problems persist, please don’t hesitate to create a new thread :slight_smile:

1 Like

Thanks for the update. We’re desperate @Scott :frowning:

It’s affecting our business as most people in Brazil can’t use our website because of this. We rely on a Netlify function that gets served to them frequently :confused:

CDN is
x-nf-request-id: 63b24c7c-90b8-4f4b-a41f-bff7448b006a-62026476

date is July 14th 7pm GMT :frowning:

What happened guys? I’m virtually offline since last Friday :frowning:

Surely there’s something someone could do? Why is it not replicating?

Hey @tcp,

Until the team working on this have more information, my hands are tied.

One workaround I could suggest is re-creating the site and ensuring that the content is correctly served before adjusting your DNS records (or, for Netlify DNS, asking us to move them over bumplessly) to point to the new site.

1 Like

OK. Thanks for checking. That was my concern. Cool.

Well, this is not same hugo case. My hugo setup is clean and verified since a long time.

So I guess this is some client dealing badly with cache or saved pages.
So at the moment I’ll consider it as solved, and will keep on looking.

Anyway thanks for validating that all node serve the same version. That was the main concern.

1 Like


We had to dive pretty deep in to this one! We’ve performed some pretty heavy cache changes for you to remediate the problem. Sorry for not following up sooner; we fixed the issue much sooner than this (11 days ago) but we continued to investigate until yesterday.