Netlify recognizes form, but does not capture submissions

I am having some issue with my site with sitename bergenhageogtrefelling hosted via netlify to

The live form is present here

I have a simple contact page with a form named contact. I am able to verify in the Netlify UI that the form has been picked up during the build process, but I am not able to receive any submissions. I have tried adding recaptcha, removing recaptcha, renaming the form, but whatever I try I just cannot seem to get it to work. All the input fields have a corresponding name attribute.

It has worked in the past. My only change this time was that I switched what repository I am fetching my site from, but I cannot seem to comprehend that that could be the issue. I have setup my own custom domain, but that has also worked before.

Any help regarding form submissions are greatly appreciated.


As far as I can tell, you have (somewhere in your source code) two copies of this form:

I believe the submission I just sent should show data (though I cannot see your form data), here:

Do you see a submission from “” there with data for your navn, epost, and beskrivelse fields?

If so - perhaps you were looking at the wrong copy of the form?

Yeah, I tried to give the form a new name, to see if Netlify would recognize it and start accepting submissions. It did recognize it, but it did not accept any submissions. However, yesterday I discovered that if I removed the action="/mycustomsuccesspage" from the form-attribute, then I was able to successfully receive submissions. Not sure why it started to work then. The weird part about that “fix” is that I am still able to see my own custom success page, and not the generic one from Netlify. Not exactly thrilled about that, but at least I am able to receive submissions as of right now.

I would love to understand why it kinda works without the action-attribute.

I did also see your test submission.

tor. 11. jun. 2020 kl. 02:06 skrev Chris fool McCraw via Netlify Community <>:

Hard to say without more details.

You could link me to an old deploy with the form failing to work, if you’d like me to look further (not sure if you knew but there is a permalink for each deploy, as shown in this screenshot of the deploy listing page):