Netlify Dev won't start with Angular

I am running an Angular: 8.2.14 application on a Macbook Pro 13’.

My problem:
I am trying to run netlify dev inside my angular project. After entering the command in th cli I just get:

◈ Netlify Dev ◈
◈ Starting Netlify Dev with undefined

The server doesn’t start.

In my netlify.toml file I have:

command = “npm start” # I have also tried ng serve
port = 3000 # Port that the dev server will be listening on
functionsPort = 34567 # port for functions server
publish = “dist/my-app-name”

What I have tried

  1. I tried using yarn instead of npm, still having the same problem.
  2. I ran “npx react-create-app app-name” followed by “netlify dev” which worked fine!
  3. I tried reinstalling the netlify-cli -> Didn’t help

My Question
What could possibly be wrong? Is this a bug?

Does someone have any experience with Netlify Dev, or at least how to debug it?

Sounds like it might be a bug, but I’m not sure. Thank you for filing it here: ! Hopefully one of the developers will be able to look at that for us soon.

Thank you! I was looking forward to using functions with Angular. Hopefully, I will be up and running soon.

1 Like