Netlify Dev local server NOT working on port 8888 for functions

  • Site Name: https://google-cal-event-page.netlify.app
  • Expected behavior: Local dev server ready at port 8888 every time I run netlify dev
  • Current behavior: Only occasionally, I get the message that the local server is ready at port 8888

I will very occasionally get this full response:

When that happens, the dev sever opens up automatically using port 8888 (as I’m used to it doing) and I can open the function using port 8888.

About 90% of the time, I’m getting this message.

(in other words, no message that local 8888 is ready). In those instances, port 8888 will not work for my functions and I have to manually type the Functions server is listening port #. Even then, I’m unable to access my local functions in dev without cors errors and other trouble with client-side code when port 8888 doesn’t work properly.

I’ve used serverless functions for months without any trouble across multiple different sites without any trouble. Any help you can give would be a big help. Thanks!

A few things I’ve tried:

  • I do have two netlify accounts. I’ve ensured I’m logged out of both and then log back in with the netlify CLI to the correct account
  • I’ve unlinked and relinked the site
  • I’ve completely uninstalled/reinstalled netlify-cli globally and in my local dir
  • I’ve restarted my machine (usually when I do that, it will show the local port the first time I run netlify dev.
  • I’ve tried to declare a port in the command netlify dev -p 8888 and by declaring [dev] with instructions in the netlify.toml file

Hi @cpenned

What version of Node are you using? There is an open issue with regards ntl dev and v17

There is also another open issue regards Vite that is possibly relevant in this instance

3 Likes

Ah! that was it. Down graded to 16.3 and it worked like a charm. Thanks!

1 Like