Netlify dev - functions redirect not working


Newbie of Netlify functions here!

I am setting up a new project using CRUD functions, following these two tutorials
Create your first Netlify functions
Building Serverless CRUD apps with Netlify Functions & FaunaDB

However, when I use the command netlify dev, my simple helloWorld function is not accessible. I think there might be something wrong with my configuration, since the app is looking for the function in port 3000, while according to the docs the function should run in port 8888

Could someone take a look at my project setup please? Specifically the netlify.toml file. This is my repo for the project, which follows the youtube tutorial.

Thank you!

If you go to localhost:8888 in your browser, your Functions will automatically connect to localhost:8888/.netlify/functions.

Hi @hrishikesh, when I run ntl dev, I have this error in the console

wasm streaming compile failed: TypeError: Failed to parse URL from /opt/homebrew/lib/node_modules/netlify-cli/node_modules/netlify-redirector/lib/redirects.wasm

Is there something I should be changing in the configuration? My version of node is v18.4.0 and netlify is netlify-cli/10.7.1

Not sure if this is related, but CLI doesn’t work well on Node 18:

Does the issue occur on Node 16 too?

That was it indeed! I downgraded to node 16.0.0 and it worked!