Netlify deploy with cli and give error Not found

I created my project at first, I ran it, then I delete the application, , generate the cli site again and load it with it, it gives an error, » Error: Site not found what can I do

Hi there, glad you found us :wave: before we can help you, we need a little more information on the issues you are facing.

First, have you looked through this resource? It is a compilation of all of our build and deploy resources. This is a good starting point.

If you have worked through those guides and are still encountering issues please share the following information:

  • the name of your build instance: “
  • what you have already tried
  • any error messages you have received in your terminal window or in the developer console

Hi, would you tell me how you solved this? I’ve got the same error message, and also it is deploying to another site.

If you can share your site name, we can help you with that.

You could use it like this: netlify deploy --site siteId

1 Like

Hi @dmitrylitmanovich thanks so much for sharing your solution. We appreciate the feedback and I’m sure it will help other community members.