Netlify deploy fails at build phase. Please help deploy my site

My Build log says

6:57:49 AM: Failed during stage ‘building site’: Build script returned non-zero exit code: 2 (Search results for '"non-zero exit code: 2"' - Netlify Support Forums)
6:57:46 AM: failed Building production JavaScript and CSS bundles - 8.364s
6:57:46 AM: error Generating JavaScript bundles failed
6:57:46 AM: Can’t resolve ‘gatsby-background-image’ in ‘/opt/build/repo/src/components/Reusable’
6:57:46 AM: If you’re trying to use a package make sure that ‘gatsby-background-image’ is installed. If you’re trying to use a local file make sure that the path is correct.
6:57:47 AM: ​
6:57:47 AM: build.command failed
6:57:47 AM: ────────────────────────────────────────────────────────────────
6:57:47 AM: ​
6:57:47 AM: Error message
6:57:47 AM: Command failed with exit code 1: npm run build (Search results for '"non-zero exit code: 1"' - Netlify Support Forums)
6:57:47 AM: ​
6:57:47 AM: Error location
6:57:47 AM: In Build command from Netlify app:
6:57:47 AM: npm run build
6:57:47 AM: ​
6:57:47 AM: Resolved config
6:57:47 AM: build:
6:57:47 AM: command: npm run build
6:57:47 AM: commandOrigin: ui
6:57:47 AM: environment:
6:57:47 AM: - SNIPCART_KEY
6:57:47 AM: publish: /opt/build/repo/public
6:57:47 AM: publishOrigin: ui
6:57:47 AM: plugins:
6:57:47 AM: - inputs: {}
6:57:47 AM: origin: ui
6:57:47 AM: package: ‘@netlify/plugin-gatsby’
6:57:49 AM: Build failed due to a user error: Build script returned non-zero exit code: 2
6:57:49 AM: Failing build: Failed to build site
6:57:49 AM: Finished processing build request in 1m6.257s

Hi there, glad you found us :wave:t6: before we can help you, we need a little more information on the issues you are facing.

First, have you looked through this resource? It is a compilation of all of our build and deploy resources. This is a good starting point.

If you have worked through those guides and are still encountering issues please share the following information:

  • the name of your build instance: “
  • what you have already tried
  • any error messages you have received in your terminal window or in the developer console