As Node.js 10 is out of the maintenance window we will be dropping support for it and require at least Node.js
^12.20.0 || ^14.14.0 || >=16.0.0 for the Netlify CLI.
This has the benefit of using new features available in Node.js like ECMAScript Modules, removing dependencies that won’t be required after the update and upgrading others to the latest version.
- It will be done behind a major version bump
- package.json engines field will be updated accordingly
- If you’re installing the latest version of the CLI in continuous integration (CI) that is running Node.js 10 (e.g. running
npm install -g netlify-cliinside a GitHub action), that CI job will probably error out (the nature of the error depends on the package manager you’re using and the settings passed to it). We recommend either using a specific version range or updating the CI Node.js version to Node.js 12.20 or greater.
- If you’re installing the CLI locally in a Node.js 10 environment you should get a relevant warning/error message saying the CLI is meant to be used on Node.js 12.20 or greater.
This change is released in v.8.0.0
If you’re already running Node.js 12 or greater no action is needed on your part