Need help debugging "Version '12.18.0' not found - try `nvm ls-remote` to browse available versions."

Everything (very basic gatsby/prismic basic app) was working and deploying wonderfully until suddenly it wasn’t - I changed no code except for some SCSS. I then tried to remove the last bit of script I added though it should not have been consequential. Everything builds locally without problems, but when I try and deploy thru git in the last 30 mins, I get failures with very little useful trace to help me figure out what it is I did. Thanks! A “passable” version is currently deployed but I’d really like to add the UI improvements before official launch on Monday.

Latest deploy attempt is:

I’m seeing the same error. It’s probably a temporary issue on Netlify’s end, see, e.g., .

In fact I joined precisely to post about this problem, and saw your post first thing. :frowning_face:

Cloudflare seems to be having a problem.

looks like it was a temporary problem unrelated to netlify, @tyn! i see that your latest deploy succeeded. Cloudflare was having issues earlier today, which affected access top lots of npm packages.

I am having the same issue. New site - I’m totally at a loss of how to fix this. Anyone else run across this?

its a cloudflare issue

I don’t see anything on that page that at all refers to the problem I am having.

1 Like

getting this error, no changes

Version ‘10’ not found - try nvm ls-remote to browse available versions.

Saw this: Need help debugging "Version '12.18.0' not found - try `nvm ls-remote` to browse available versions."

but still not sure how a cloudflare issue, and i for sure know 10 is a valid value because neither do i set it in nvmrc or anything, this is just a simple gihub pages jekyll deploy which used to work

Hi @tyn,
Looking at your Netlify deploys page, it seems that you made it work. I’m having the exact same issue here. Do you think you can share the solution you found here ? That would be amazing.
Thank you very much in advance,

It seems that there is active issue. Look at


Thanks for posting that, @nurgasemetey! I came here to link to that but also the apparent root cause described here:


Cloudflare’s network is used to serve node and node module files for installation, unfortunately.

1 Like

I am sorry, but I don’t see how they discuss this issue at all or how to troubleshoot it. That link looks like a collection of people complaining about centralised web architecture.

Is there a solution to this problem? I registered a domain with netlify for the sole purpose of launching hugo static site. Should I try something else?

Let me recap the situation, @jpiaskowski - I did not do that in this thread, thanks for the call out!

  1. our build system downloads node and node packages during most builds. If you use node during your build (do you have a package.json, yarn.lock, or package-json.lock file in your repo?), this includes you. Hugo does not use node natively, but most builds on Netlify do.

  2. Cloudflare’s service serves the downloads for and, which are the ones that were failing due to their outage

  3. There isn’t a good workaround for them being down.

  4. They came back up at the end of the incident, which should allow builds to work correctly now.

  5. if you still see an error in a new build, it is not related to the outage this morning, and you should use the steps here to debug and let us know if your debugging doesn’t help: [Support Guide] Debugging Netlify site builds

I was able to build my website, thank you. Having new issues with display, but I will troubleshoot those elsewhere.