My website wont publish

One day ago I made a netlify account and I put in an html code, that is valid and correct, and I purchased a custom domain from netify. however, I cannot figure out how to actually upload my website to the internet. When I click on the link for my website “” I get taken to a page that says “Pages not found” and then below “Looks like you’ve followed a broken link or entered a URL that doesn’t exist on this site”. The same problem happens when I look up my domain in google. Is there a way to fix this or publish the website?

@llukesurfer24 Welcome to the Netlify community.

If you haven’t uploaded your files yet, you will see a 404 page.

Have you tried dragging and dropping a ZIP file of your HTML files on the bottom of the Deploy page of your Netlify dashboard for this site? If not, what have you tried so far?

It does not say a 404 error, rather it is a black screen with a colorful pop up that says " Page Not Found

Looks like you’ve followed a broken link or entered a URL that doesn’t exist on this site.

Back to our site". It says that the website should be published. Is there any area to specifically press publish? Also at the bottom of the deploy page I do not see an area to drop a zip file, what does it look like or where could I drop a zip file?

@llukesurfer24 That black page with the error message is the 404 / page not found page.

If you don’t have a big “box” at the bottom of your Deploys page, then you must have auto-publishing turned on so that each time you update your files on GitHub, Gitlab, etc., Netlify grabs the new files and publishes them. There is no “publish” button, per se, if your files aren’t sent to Netlify one way or another.

Perhaps you could share a little about what your workflow is, so we can see where the process may be breaking down?

My code is in the repository on github and is a code that I have run on some other platforms that display the code, and it fully works and there is not a problem with the html script itself. I have linked that repository to the domain i purchased, and when I click on the domain link it brings me to the error 404 page. Could it be that it takes more than 2 days to publish or should that be instant? If not what should I try to do?

@llukesurfer24 then you probably have an issue either with publishing the wrong directory from GitHub, or with publishing into a subdirectory.

[Support Guide] I’ve deployed my site but I still see "Page not found”

Try downloading your deploy to see if the files are where they are supposed to be.

1 Like

I think the issue is that I have not put in a publish directory or a maybe a build directory. What is a directory, and what should I set my publish directory to?

howdy luke, how are you deploying (uploading) your site? are you dragging and dropping it or deploying it from github?