My deployed website keeps telling me i have a broken link

The link above keeps telling me it’s broken even though i have a index.html file.

I have another site deployed on my page that works just fine, however, this is the second project i am trying to deploy that simply won’t work.

Can someone please tell me why that is?

A frustrated Dev

Welcome to the forums @GregInTech14

Is the index.html file in publish directory?

Placed it into my shared folder and i am still receiving the same message.

Are you deploying from git?

If so, can you share
a) the repository you are deploying
b) the build setting from the Netlify UI.

Im currently deploying it from my desktop.

Unfortunately, I am fairly new to this, mind explaining how i can share the netlify UI with you?

A screenshot of the build settings will be enough, it’s just to check what you have set.

Likewise seeing the repo is really just a question to try and determine the folder/file structure you have, so it can be confirmed against the build settings.

E.g. You may be telling Netlify to deploy one folder, but have your files in another etc.

1 Like

One folder contains my html and css and js(although that file is empty at the moment)

the other folder has all the images

Thank you so much for that. I responded to the original question from (coelmay)

Please let me know if my response was adequate enough or if i misunderstood something.

@GregInTech14 The screenshot needed is of the Build & deploy settings (shown in the sidebar of the screenshot you took of the General -> Site details)

With the folder that you’ve shown, is that the one you’re uploading?
So you’re uploading a folder with a structure of:

  • Linktree Website
    • main site
    • Images

There’s no index.html in that folder?

Also to make things easy on yourself you should avoid spaces in folder/filenames and be aware of case sensitivity (e.g. use all lowercase).

In addition to the above.

The error that you’re seeing on is the same one that is seen when the site instance doesn’t exist at all, for example with something random like

In the screenshot you have supplied I can see that your Site name is kingjameslinks which would end up with a url of

Visiting that shows that it is a site instance, but doesn’t have an index page.

Factoring in the previous notes you’ll find that your site is currently at

Thank you Nathan.

Sorry about the late response. Just now getting back for work.

I will take the screenshot immediately.

I have an “index.html” file inside the “main site” folder.

I will keep in mind to avoid spaces and case sensitivity for future reference.

That’s what I’d guessed, as per the site being where I had linked to.

You can specify which folder is deployed using the Build Settings

However, just note that if you were to specify main site that the Images folder wouldn’t be deployed.
You would then need to have it be inside of main site for it to also get deployed.

1 Like

Thank you so much Nathan.

After some trial and error i finally got it all to work.

Thank you very much for your help.