Mime problem (mime type is not allowed)


I have deployed my react website to netifly.
But as soon as I try to see it I see a message that the mime-type of the site is
application/octet-stream and that is not allowed.

How do I solve it so I can see my first react site build

Hey Roelof,

this thread may help: https://answers.netlify.com/t/react-vite-js-page-shows-empty-page-on-deploy/74210

if not, please provide your site name so we can look further into this.

it helps a lot but the only thing is that I cannot find the build settings.
my site is : https://keen-medovik-e0f69e.netlify.app/

That netlify url is returning an error. Can you please check it’s correct.

You can find your build settings here:
Site settings > Build and deploy > Build settings
Please take a screen shot and add it to the thread. A link to your git repo would also be extremely helpful :slight_smile:

here a sceenshot with hopefully all the data you need

According to that screenshot, looks like you didn’t set a build command or a publish directory in your site’s netlify.toml file. You can do this in the UI site settings if you link the repo for your site to Netlify. Here is another link to the solution from the other thread for your reference:

Hmm, never knew I had to make a netifly.toml file
I followed this tutorial : Deploying a Static Site | Vite

expecially this part :

Netlify CLI

    Install the Netlify CLI.
    Create a new site using ntl init.
    Deploy using ntl deploy.


# Install the Netlify CLI
$ npm install -g netlify-cli

# Create a new site in Netlify
$ ntl init

# Deploy to a unique preview URL
$ ntl deploy

The Netlify CLI will share with you a preview URL to inspect. When you are ready to go into production, use the prod flag:

# Deploy the site into production
$ ntl deploy --prod

and I did those steps

Can you help me to find out how the netifly.toml must look like

That’s a valid and reasonable way to deploy; we didn’t know you were using the CLI before.

As far as I can tell, your site is working correctly now:

  • you’ve deployed 5 files, none of which will use that reported mime-type (they are all files with well-understood mime types, none of which will end up as octet-stream unless you specially configure something)
  • going to https://keen-medovik-e0f69e.netlify.app/ seems to show your app without any warnings

Please let us know in case you still see this happening!