"Looks like you've followed a broken link" when viewing site

Hi @Neha. It seem you are trying to deploy a completely static site from Github. Netlify however needs some kind of build command for your site do deploy.

If you want to use continuous deployment on Netlify, you’ll have to use a static site generator or another build command (like npm run build etc).

You can deploy static html, but you’ll have to use the drag and drop interface at the bottom of the dashboard.

Hey @Neha and @tomrutgers! that’s actually not quite correct - you can deploy a static html-only site to Netlify, you don’t need a static site generator. You can just leave the build command blank in that case. (tom’s comment that you CAN use drag n drop is correct!)

The publish directory needs to be the directory that contains the index.html file. The base can be blank in this case.

For example, here are the settings for an html only site of ours that does not have a build step:

1 Like

Oh wow @perry, I did not know that! Sorry :zipper_mouth_face:

totally fine! it lead to a productive discussion about how very experienced netlify users (and you are about as experienced and as knowledgeable as they come, more so than our staff!) sometimes don’t know you don’t need an SSG. We are going to figure out how to make this knowledge more widely known! so thanks, actually!

1 Like

My build settings are quite the same. i had also tried to add the ‘/* /indel.html 200’ to my html code but nothing seems to work. i am still not getting how to solve this issue

thank you.

Actually, your site is deploying just fine @neha. I took a look at your repo, it’s missing an index.html page. The other pages work: https://gracious-rosalind-8e0ad5.netlify.com/about.html

Hey, I’m new here and I’m having problem deploying my website.
I built a simple website that doesn’t need a build command, I linked the corresponding github repo to netlify, deployed and got the url https://sharp-einstein-d231a0.netlify.com created, that says page not found. Can you please tell me what I did wrong ? Thanks !

Can you share your repo?

Sure : https://github.com/henridelozanne/space-tetris

Is it because the index.html is not at the root ?

Indeed! You’ll have to set your base directory to ‘code’. You can read all about that here: https://docs.netlify.com/configure-builds/get-started/#definitions

That makes sense ! However in my netflify’s project page in the ‘build settings’ section I tried to add ‘code’ or ‘/code’ as the base directory and it doesn’t seem to work, also tried with the complete path ‘https://github.com/henridelozanne/space-tetris/code’ but I still have a ‘page not found’… Is there something else I’m missing ?

As it wasn’t working I modified my github project to set my sub-folder ‘code’ which contains the index.html as the main repo. I then deleted the ‘code’ base directory on netlify but I still have the ‘page not found’ message. Any idea what is wrong ?

thank you sir, the link you have sent in the above mail totally works. but when i log in through netlify main page, i still get the same error message. may be as you said i am still missing a index html page. how am i supposed to add that.

thank you

You can either make a new html file to your Github repository that you want to use as a homepage and call it index.html or rename a file already present in your repo to index.html . In the latter case, you’ll have to update your navigation, probably.

I cloned your repo, created a new site and left all the build setting empty. It deploys perfectly: https://naughty-bose-2a3616.netlify.com/. Maybe try starting fresh?

Indeed ! I created a new site from the modified github repo and now it works fine :slight_smile: Thanks a lot !

1 Like

thank you so much sir. all sorted! THANK YOU!

1 Like

@tomrutgers, I have the same problem with my site deployment. I am completely new at this and have no idea what I’m doing or how to fix my problem. Are you able to help me?

My repo is: github.com/mleonard97/Netpricecalculator

Hi @mleonard! It looks like you’ve added a zip file to your Github repo. Simply remove the zip from the repo and add its contents. Use the build settings @perry describes in the post above and you should be good to go.

1 Like

I think I made the correction in Github… but it’s still not working. It is a single page of html, so there is no directory or index page. My settings must be wrong.