Issue with "ntl dev" and Vue verbose output

I noticed something interesting with a Vue app I’m working. If I run it with “npm run serve”, it runs fine, but obviously I can’t use local Netlify functions. If I run with “ntl dev”, it still works fine, but I get an incredible amount of console messages. Here is an example:

<s> [webpack.Progress] 76% basic chunk optimization MergeDuplicateChunksPlugin
<s> [webpack.Progress] 77% chunk optimization
<s> [webpack.Progress] 77% advanced chunk optimization
<s> [webpack.Progress] 77% advanced chunk optimization SplitChunksPlugin
<s> [webpack.Progress] 77% advanced chunk optimization RemoveEmptyChunksPlugin
<s> [webpack.Progress] 77% after chunk optimization
<s> [webpack.Progress] 78% module and chunk tree optimization
<s> [webpack.Progress] 78% after module and chunk tree optimization
<s> [webpack.Progress] 79% basic chunk modules optimization
<s> [webpack.Progress] 80% chunk modules optimization

None of this prevents me from getting stuff done, but I’d love to disable it. . I tried ntl dev -c "npm run serve" and I get the same.

Hey @cfjedimaster :wave:t2:

Were you able to confirm that running the -c flag did indeed change the command that dev run to spin up the Vue process? Wondering if instead you might want to define the dev parameters a tad more declaratively in your Netlify.toml file as described in (this link is to a specific header in the document, “netlify.toml [dev] block”)

And see if that could help?



From what I could see, using -c "npm run serve" did not change the output, it was still verbose. I don’t know what ntl is doing to make the output more verbose. Looking at ntl dev --help, I don’t see an option to make itself a bit more verbose so I can see what it’s doing.

Well digging into the dev code further, it looks like the inferred command for a vue project would be vue-cli-service serve so perhaps that’s where the verbosity is coming from? Not a vue user myself so not sure :slight_smile: I’d say try the Netlify.toml [dev] configuration and see if that helps


Yeah, but that’s the same thing npm run serve does. I wonder if ntl is setting some environment flag that the Vue CLI picks up on.

Seems like that might be something eventually running webpack --progress - perhaps there’s a webpack config somewhere that specifies it off the command line since that is supposed to be possible (cf