Issue with Netlify Build Version

Can you specify the ‘@netlify/build’ version? It seems that a change in the build has messed up the compiled version of my app.

I’ve deployed the same repo + commit between yesterday and today and the end webpage is completely jacked. I’ve gone through all the logs and diff’d them and it seems the only thing that is different is the following lines.

3:31:22 PM: ┌─────────────────────────────┐
3:31:22 PM: │        Netlify Build        │
3:31:22 PM: └─────────────────────────────┘
3:31:22 PM: ​
3:31:22 PM: ❯ Version
3:31:22 PM:   @netlify/build 3.1.4
3:31:22 PM: ​
3:31:22 PM: ❯ Flags
3:31:22 PM:   deployId: 5f21ce69454708000819ca0f
3:31:22 PM:   mode: buildbot
3:31:22 PM:   timersFile: /tmp/substage_times.txt


2:27:14 PM: ┌─────────────────────────────┐
2:27:14 PM: │        Netlify Build        │
2:27:14 PM: └─────────────────────────────┘
2:27:14 PM: ​
2:27:14 PM: ❯ Version
2:27:14 PM:   @netlify/build 3.0.1
2:27:14 PM: ​
2:27:14 PM: ❯ Flags
2:27:14 PM:   deployId: 5f2310db76547b9107049d3d
2:27:14 PM:   mode: buildbot
2:27:14 PM: ​

The build using version 3.1.4 worked completely fine.

Below are links to the two different build logs.

Any help would be great, thank you!

Good Build -
Bad Build -


To start, I’d be tempted to:

  • Ensure that the content between commits isn’t different
  • Give our build debug guide a once over, making sure dependencies match and then building locally

Thanks for the reply!

I’ve built and deployed the same commit (i.e. same source) and got two different results. The only difference was the build version.

Though I am looking at the debug guide and am trying a local build with the Netlify Build Image

I’ll update after running the builder locally.

1 Like

I’ve run the build with the build image. At first I pointed it to my local clone of the repo and built perfectly fine. But with a fresh repo pull it fails. This is a dependancy issue on my end and not Netlify’s. Marking solved.