Issue with Domain Configuration from Ionos to Netlify (wrong nameserver ?)

Netlify Site:
Costum Domain:

Hello Netlify Support,

I’m reaching out because I’m running into a problem with my domain setup. I purchased a domain ( from Ionos and tried to change the nameserver to Netlify’s ( However, Ionos seems to have an issue with this, as it’s displaying an error message saying “Invalid nameserver settings - The personalized nameservers could not be resolved.”

I tried to validate the nameservers using the DENIC Check but it didn’t solve the problem.

Interestingly, the domain worked fine yesterday, but only without the ‘www’ prefix. The Netlify app URL I’m using is

Could you please help me understand what’s going wrong here? Specifically, I’d like to know why the nameserver setup isn’t being accepted by Ionos and how I can ensure that both ‘www’ and non-‘www’ versions of my domain direct to my Netlify app.

Any help you can provide would be much appreciated.



While dig shows the correct nameservers

% dig NS	86400	IN	NS	86400	IN	NS	86400	IN	NS	86400	IN	NS

whois does not

 % whois | grep 'Nserver'

Suggest reading through the following support guide

as well a checking out other threads in these forums related to IONOS and also the IONOS Help Center

Thank you for your answer, unfortunately I cant find a solution for my Problem.

If I do a Predelegation Check with denic, the check fails.

You can see them here:

This seems like a similar issue to Help me with ip of netlify nameservers.

Based on the screenshot you’ve provided and the answer provided in that thread by @luke Help me with ip of netlify nameservers - #14 by luke can you change the nameservers you are using from to


And use
1 Like

done, now I have to wait i guess :slight_smile:
Thank you very much

It seems to work for, but the with www ( it seems not to work, is my primary domain in my dashboard.

I dont know why the redirect is not working.

Do I have to change something in my DNS records ?

For me redirects to

Quite likely you tried too soon and the response is cached. Trying a different browser, or different device my yield different results.

It will fix itself in due course.

% curl -I
HTTP/2 301
content-type: text/plain; charset=utf-8
location:      # <-- Shows redirect
1 Like

I had the same problem again with another domain.

After an exchange with @jasiqli , he gave me the tip that I can check the correct nameserver myself.

Just enter the data at

If there is an error, the correct nameserver is listed under NS host names (see screenshot).

Thanks again to @jasiqli

It seems that this is a bug with the netlify ui not showing the correct nameserver for the registered domain.

In order for us to investigate if this is a bug please attach a screenshot of the UI where this is inaccurately displayed…

Hey @SamO

The error is in the Netlify UI when adding a domain. The nameservers displayed where in this instance incorrect. This is the same as @luke mentioned in another thread

Hi @SamO

It looks like the bug exists in two places,
I can’t provide a screenshot of the first one because I can’t open the modal anymore.

But it is when you just change the domain and netlify waits for the DNS confirmation.
When clicked, a modal opens in which the nameservers are. In this modal you see the wrong nameservers.

Also the wrong nameservers are in the DNS panel under Name Servers (see screenshot).

Hi @Karim,

The correct nameservers should now be updated in the UI.

1 Like

Hi @hrishikesh, thank you !

It seems like it is fixed for (

but for (

there is still the wrong nameserver in the UI.
Thanks for your help.

That should be fixed as well.