Is Netlify mangling my href quotes?


Double quotes are changed to single quotes.
Apostrophe is escaped.
.html is removed?

That is some massive changes that are causing bugs.
Trying to understand why.
Anyone have insight?

Edit: Using wayback time machine I can see this error was introduced around jun 28. Did netlify change their deploy process in some way around that time?

What site is this about?

Try tyrning off Pretty URLs: Build & deploy | Site configuration | sageguide | Netlify

Yep that fixed it instantly.


Could you try enabling pretty URLs back and check if now it’s working?

The problem with the special character ’ in the href should be solved now.

1 Like

Yes it works with pretty URLs enabled now.

1 Like

Bug keep existing:

<a href="../fr/index.html" onclick="document.cookie = 'nf_lang=fr; path=/ ; SameSite=Strict'">FR</a>

Give with “pretty link”:

 <a href='/fr/' onclick='document.cookie = \'nf_lang=fr; path=/ ; SameSite=Strict\''>FR</a>

This should now be resolved for you as well.