Invalid SSL Cert; security certificate is from *

Hi there,

I’ve gone ahead and setup two domains for my client on their Netlify deploy however it appears that both have SSL certs from Netlify and these are being served invalidly. Futher information on Chrome states

This server could not prove that it is  **** ; its security certificate is from  ***** . 
This may be caused by a misconfiguration or an attacker intercepting your connection.

Both domains and do so for my domain Is there something I’m missing? My google-fu has proved fruitless.

Too I’m running my site through Cloudflare then to Netlify, is both SSL certs being active causing an issue perhaps? I’ve turned off running through their network and exposing Netlify and this issue persists.

Appreciate your help!

EDIT: Appears Netlify had been stuck on Verifying my DNS. I hit the Recheck button and it appears to have gone to a green tick. No status update yet as to my certs being renewed.

Here’s hoping! It is now as below…

Fixed: Time is a key factor my friends. SSL is now actively in place & happy :slight_smile:

Google-fu experts who find this thread should give it a few hours. My issue resolved itself after manually “verifying” the DNS.

Hi, @jakehwll. Welcome to the Netlify community site and thank you for the follow-up to confirm the SSL certificate is working correctly now. :smiley:

Why did it take so longer? I’m not 100% certain but my best guess would be time to live (TTL) values causing the previous DNS records to be cached for a time:

I’m glad to learn it is working now though!

Not entirely sure to be completely honest, definitely thanks for the response though.

My TTL is set to the default, Auto on Cloudflare’s end so whatever the default TTL is I assume?

You can tell using a command like dig - but only BEFORE you make changes :slight_smile: - since the value that matters in this case is the cache timeout attached to the PRIOR value.

$ dig

; <<>> DiG 9.10.6 <<>>
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 41222
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 512
;	IN	A


that 300 in the last quoted line is the TTL in seconds. I think cloudflare’s general default is 5 minutes for CNAME records, but hard to be sure how you had things configured before. Also thanks to the distributed nature of DNS, some servers can hang onto things for too long and it can be hard to troubleshoot but the link from the UI in case the certificate has trouble provisioning has good advice to nudge it along:

specifically step 4 can combat those recalcitrant servers.

1 Like

If anyone comes to this thread via google like me then you might find it helpful to know that my issue was fixed in a similar but different way: by clicking renew certificate under domain management / https

(I didn’t appreciate that this was a required step in moving the domain name to netlify managed DNS - perhaps because this was the second address I moved to point to the same and didn’t have to do it for the first one - ?)

1 Like

Thanks for following up on this thread and letting us know, @aewshopping! We are glad you have found a solution. Happy building :rocket: