Home
Support Forums

Introducing new collaborative Deploy Previews!

For those of you — like me — using a Content Security Policy, and not seeing the button, add:

  • frame-src https://app.netlify.com, and
  • script-src https://netlify-cdp-loader.netlify.app/netlify.js

Note, Chrome still raises 2 warnings:

  • Origin trial controlled feature not enabled: 'display-capture'. (anonymous) @ netlify.js:1
  • Error with Permissions-Policy header: Unrecognized feature: 'interest-cohort'.

Oh, ok, that makes sense, though the blog post could have been more explicit about that, it’s easy to miss that it’s only available for Github so far…

Don’t really want to criticise as it does seem like a nice enough feature but… is there no way to disable it?

Seems a bit presumptuous to assume everyone either wants this feature or is ready to use it straight away. An opt in toggle (or even an opt out) would have been nice here.

1 Like

Hey there, @nicksnell :wave:

Thanks so much for reaching out and sharing this feedback. Rather than disable the feature, there are ways to avoid the feature if you wish. You can read an explanation here!

Thanks, that does make sense, but it’s not ideal as it means we have to change our process to deal with the change - I’d rather we choose to accept the feature into our workflows.

Maybe for small teams this doesn’t matter much but for larger/enterprise size teams, this sort of thing is disruptive.

I think we will add a CSP to block the button as mentioned above.

2 Likes

Thank you so much for this feedback, @nicksnell. I will make sure we share this with the appropriate team.

For some reason I’m not getting the new Deploy Previews.
Not sure if I’m doing something wrong.
I’ve tried creating 2 new PRs since the announcement to a site I’m working on and I’m not seeing anything new.
The code is hosted on GitHub so I don’t think it’s the same issue that @richpars was having…

Got a link to your repo or mind Gist-ing your page(s), @lukebennett88? Suggestions would include making sure that the asset is a valid HTML file, ensuring it includes the <body> element.

Howdy! I’ve been trying to use the new collaborative Deploy Previews but hitting sign in issues when opening the new draw on the previews themselves. I believe I’ve already granted Netlify extra permission on my GitHub account, despite hitting some GitHub 404s. When I try it out I experience the following:

  1. Click to view deploy preview
  2. See deploy preview and new Netlify draw button
  3. Open draw and see a “Sign up to Netlify” view, plus a “Log in” link
  4. Click the log in link
  5. Netlify dashboard opens up in a smaller window
  6. Close window and repeat the above steps

My suspicion is that I’ve somehow broken the permissions when I granted it, and it’s now malformed in some way. It could also be because I’m using Safari and their cross-site tracking is blocking the tool for working entirely.

PS. I’m not concerned at all that isn’t not working as expected, everything else works perfectly well for me and my clients. I just wanted to report this issue so it’s written up somewhere and that it might help others :+1:

Love this feature! But is there a way to disable it for a preview deployment or via URL parameter? When doing a lighthouse report on a preview the added scripts will have a major negative impact on the score

@DavidDarnes, interesting. I’ll pass it to the team. Anything notable in dev tools? Does it happen in an incognito window?

@maggo, there’s a rook of suggestions here for you: Netlify GitHub App permission updates with collaborative Deploy Previews - #3 by amussap

No errors in console when viewing the deploy preview or opening the drawer. There’s an error on the Netlify app itself, 404 for app.bundle.js.map. It does work in Incognito! I’ve tried my clearing cache and logging out and back in with no luck in a regular window. Very weird

Hey there, @DavidDarnes :wave:

Thanks for following up, we appreciate it! The team has an open github issue to address what is happening here. In the interim, could you attempt to use it from a different browser? Thank you!

Hi @Scott,

The repo is private, but here’s the deploy preview:

It’s a pretty standard Gatsby site, and all the markup is valid as far as I know.

Happy to provide more info if that helps.

Thank you! Great to hear, however I’m really in no rush to use the new feature. Just wanted to let people know incase others were experiencing the same issue :blush:

Hey there, folks

The fix for this was just rolled out! Please attempt again and let us know if it is now working for you :slight_smile: We appreciate your patience and feedback.

1 Like

It’s a great feature, but can we disable it?
It makes impossible to test the mobile version of our application.
A lots of web applications mobile version has a menu or navigation bar at the bottom and this feedback icon covers the left part of this area.

Or you should make it movable…

Hey there, @negentropics :wave:

Thanks so much for reaching out and sharing this feedback. Rather than disable the feature, there are ways to avoid the feature if you wish. You can read an explanation here !