Initial deployment fails with no logs available

Hi there!

I am running into trouble deploying a new site from a GitHub repository. Setting it up worked, build command was recognized from the Netlify.toml file. This site is similar to another one I deploy successfully already. But the build keeps failing, with an error that build logs could not be retrieved.

Local npm run production command succeeds.

The Netlify-cli does, however, give me trouble in any project I try to use it, it crashes with something like this on top of the stack:

 Fatal error in , line 0
# Check failed: allocator->SetPermissions(reinterpret_cast<void*>(region.begin()), region.size(), PageAllocator::kNoAccess).

The affected Netlify site is boring-chandrasekhar-502c4d. But there’s nothing there yet because it has never been deployed successfully.

Any advice?

Thank you!
Marco

This morning, the logs worked again, and I was able to resolve my issue. Seems that for some reason, even if Eleventy depends on Markdown-it already, I needed to include it in my package.json when I wanted to modify its plugins from .eleventy.js. Don’t know why I didn’t need to do this in my other project that has a similar setup.

1 Like

Hi Marco, I ran into the same error and am not sure how to fix because I’m a non-developer. Is there a specific command line I can run to include Markdown-it in package.json? Thanks!

Hi, @reecebguida. The answer depends on whether you use yarn or npm for dependency management.

If you use npm the answer can be found on the npm package page for this package:

Quoting that page, the command is this:

npm i markdown-it

1 Like

Hi, @luke! Thanks for helping and providing further context. I use npm, but am sad to report that command didn’t work.

I will provide further context below and recap how I got this error, because it seems my use case is different from @MarcoZ’s. Please let me know if you need any additional information! I appreciate your patience with my non-dev lingo.

  1. I follow all the instructions on this page successfully up until step 4: https://www.gatsbyjs.com/docs/tutorial/part-zero/
  2. The command gatsby develop does not execute.
  3. I receive the following error# Fatal error in , line 0, which continues in the next line Check failed: allocator->SetPermissions(reinterpret_cast<void*>(region.begin()), region.size(), PageAllocator::kNoAccess).
  4. I hit control + C to start up the command line again
  5. I run the command npm i markdown-it
  6. Everything is up to date with zero vulnerabilities
  7. I retry gatsby develop
  8. The error in step 3 repeats

This is probably overkill, but I use a Mac with an M1 chip. And here is the elaborated failure message:

Hey @reecebguida,
This does look related to the M1 chip- looks like @MarcoZ filed an issue (thank you!!) on our CLI repository in case you want to chime in there or follow along for suggested workarounds: Crash on M1 Mac when calling many commands like login, link, etc. · Issue #1800 · netlify/cli · GitHub

1 Like

Hi @Jen thanks for referring me to that issue! I commented there in the hopes of sparking up the conversation so we can get a solution, since it seems like @MarcoZ’s issue resolved itself according to the discussion on this page. I’m so excited for my Gatsby blog to go live, and appreciate everyone’s support.