Increase Netlify Functions Lambda Invocation Timeout

My team and I are facing an occasional timeout that occurs when running a custom Netlify function. After reading through the community forums, it was mentioned we can reach out to support if this invocation timeout needs to be increased:

I’ve just upgraded to the Pro plan; would it be possible to increase the lambda functions timeout to the 26-second maximum?

Thank you!

Hi CipherVision,

So I can increase the function time limit, could you provide the site that you’re having this issue with? If you could provide the site name or the site ID. You can go to Site settings > General > Site details > Site information, and copy the value for Site ID and paste into a reply to this post.


Hello, Melvin. Great! Here is my site ID:

  • 13cee8ae-99e3-445e-8451-e29c48311995

Let me know if there’s any other information you might need.


Hi Melvin

I’m in the same boat. Could you increase it for my site too?


Will help me a lot, thanks!

Hi @CipherVision,

Thanks for the follow-up. I’ve increased the timeout for functions for the site to 26 seconds. You’ll need to redeploy the site to activate the new setting.

Thanks, Melvin! I really appreciate the help here.

Hi @MarcFuSa,

I’ve also increased the timeout for functions for your site to 26 seconds. Please redeploy the site to activate the new setting.

1 Like