Images in blog posts are 404 broken

PLEASE help us help you by writing a good post!

  • we need to know your netlify site name. Example:
  • DNS issues? Tell us the custom domain, tell us the error message! We can’t help if we don’t know your domain.
  • Build problems? Link or paste the FULL build log & build settings screenshot

The better the post - the faster the answer.

my Netilfy site is located at
currently it is just a next.js blog with a blog theme I got from next.js.
it is only a blog currently as I test out Netlify.

markdown and plain text blog entries work great
I thought I would try adding an image
the image is located in my GitHub repository in the images directory
I call the image: The Bible
the image is called “bible.jpg”

it looks great in marked and in the preview on the GitHub
but gives a broken 404 on the blog entry
I have tried every possible way of calling the image
including calling it from dropbox
and it always appears as 404 and broken
and I have no idea

I just installed the theme, added my domain and started writing blog posts. no other configuration has been done

please help me mr wizard


Sounds like the image source path isn’t correct. Are you able to share your repository?

Absolutely, anything you need. do you need the GitHub repository? and how do I share it?

You can post the link to your public repository here.

This is not really a Netlify issue - you should try reaching out to the creator of the template to ask how to set this up. I had the same problem when I tried your website locally.

However, a simple solution would be to put the images in public folder and link to them as /image1.jpg for example.

1 Like

I got the template on the Netilfy site, in fact I said I wanted a blog and Netilfy installed it. So I did not chose it, I thought it came from netlify. if this is not true, please help me and tell me how to get in touch with the author who is not netlify

I am looking and I cannot find where to change the template, delete the template or ask questions about the template.

You can change the content of the template you deployed in the repo you attached above. Would you mind sharing the link to the template you used?

I cannot find where I got the theme on the netlify site. it was offered to me when I first started. there is only one theme in my repo. I am not sure what I can give you

Yes, i see this now. I’m not sure why this is happening but if you’re getting a 404 you’d likely need to look at your code and debug. There’s loads of documentation online for this.