Images are loading super slow

Hello,

I’m hosting a small static site on Netlify but the images are downloading very slow.

loving-jepsen-8afe7b.netlify.app

The header images takes 4-11 seconds to download. I just tried again in private browse mode and it took more than 30 seconds.

The main domain is fitofago dot com
Any ideas what could cause this?

Thanks ifor your help

@fito Welcome to the Netlify community.

It does seem as though that image should load more quickly than it does, however it is a large image and you are serving it uncompressed. I show that it’s 2.2 MB as-is, but could be compressed to 308 KB without losing anything important – especially as it’s a background image.

You could pre-optimize each image on your site using something like ImageOptim, or maybe try turning on asset optimization in your Netlify dashboard (under [yoursite] -> Build & Deploy -> Asset optimization.

Hello gregraven,
thanks for your help. I activated the option in the netlify back-office, will check if that works.
Could there also be another thing causing this? I read also something about a possible DNS configuration issue.
Thanks

@fito If the DNS works to steer visitors to your page, it shouldn’t make an exception for that one background image. That’s not really how DNS works.

It is possible for DNS misconfiguration to cause slower load times :slight_smile: This post gets into why and how we suggest setting up DNS if you’re not using Netlify DNS:

And indeed in this case, there does seem to be some DNS weirdness. When I run host on the custom domain for the Netlify URL @fito shared, this is what I see:

% host www.fitofago.com
www.fitofago.com is an alias for fitofago.com.
fitofago.com has address 104.198.14.52

So www. is pointing to the apex domain, even though in the Netlify UI, the www. is set as the primary domain. There may be some looping happening because of that. Beyond that, the apex domain points to our load balancer in San Francisco. Together, this config means that you’re not getting any of the geo-routing capabilities of our CDN :cry: but it’s easily fixable by changing your CNAME record for www.fitofago.com to point to loving-jepsen-8afe7b.netlify.app (instead of to fitofago.com).

Please let us know if that helps or if you have any other questions on this!

Hello jen, thanks for your help. I will change the DNS configuration and I will let you know as soon as I know more.

1 Like