I'm having issues deploying a branch to a subdomain


I’m having issues pushing my git repository to a sub domain

My netlify web URL is youthful-lovelace-129c98

Everytime I push to the branch, It triggers a Deploy preview but instead I want to publish it so that I can have it as a subdomain of my custom domain. Could you please look into this and how I can fix this?

You can try adding the branch name in the Deploy Contexts section in the Build & deploy settings in your dashboard.

I already did that, It does not publish it though, it doesn’t even detect there are two branches because when I go to split test, it says you need at least two branches , I have three branches in that repository.

That’s strange. Deploy previews only get triggered for pull requests and not branches as far as I know.

Is it possible that somehow your branch is automatically triggering a pull request or something?

Hi, @sarafraghav. The deployment of other branches was only enabled five hours ago for this site. That is why other branches we not building before that.

There has only been one other branch deployed since this setting was changed and that second branch does show in the split testing page for this site.

If there are other questions or concerns, please let us know.

Hey! So This website just did’nt detect my that branch so I went ahead and created a new website in netlify and the URL is elegant-blackwell-256d34 and this detects the branch properly. It also added a new custom sub domain as checkout.fillmycalendar.net but when I visit that URL, It says not found

Could you please check this out?

It doesn’t say Not Found. It says NXDOMAIN. It means there’s something wrong with DNS configuration.

Hmm, Ive deleted the domain and added it again, I’ll let it propagate for sometime and hopefully it works.

The weird part is that https://checkout--elegant-blackwell-256d34.netlify.app/ works but the custom domain does not.

The DNS zone has an entry auto generated my netlify

This is pointed towards the main website, Shouldnt this be pointed towards checkout–elegant-blackwell-256d34.netlify.app?

There’s nothing weird there. It’s expected to work. It would have been weird if it had not worked.

Even if it was an error, your website should have worked (the one at elegant-blackwell should have been shown). So, it might be DNS propagation issue. Let’s wait for some time.

Hmm, screw it, I’ll just add the file in the master branch.

Thanks for your help!

Hi, @sarafraghav, I think part of your issue might have been that Netlify DNS wasn’t activated:

It could also have been time to live (TTL) value related:

Note, the current DNS service for this domain is not using Netlify DNS and the time to live is 6 hours (21600 seconds):

fillmycalendar.net.	21600	IN	NS	salvador.porkbun.com.
fillmycalendar.net.	21600	IN	NS	fortaleza.porkbun.com.
fillmycalendar.net.	21600	IN	NS	curitiba.porkbun.com.
fillmycalendar.net.	21600	IN	NS	maceio.porkbun.com.

This means, if you do change the DNS service to Netlify DNS, it can and will take up to six hours for those changes to take effect. Did you wait six hours before and are you sure Netlify DNS was activated?

I ask because it isn’t active now and I have no way of seeing the history of your DNS configuration at the domain registrar - porkbun.com.

I’m also not sure if you are trying to use our branch subdomain feature or not. If so, note this requires either a) Netlify DNS to be used or b) for the manual process below to be used instead:

If there are other questions or concerns, please let us know.