Identity-signup function is not being triggered

Hi Jen,
I’m having this same issue with a small test build I’m doing (using Fauna though). I’m trying to use Identity-Fauna-Stripe for assigning roles now but it won’t work (email confirmations won’t trigger and then I eventually get failed to handle signup webhook” errors (when I delete my only member). When I don’t use Fauna/Stripe my sign-in works and redirects work (with manual assignment of role).

I think the issue is the webhook. I’m new to this so I don’t know where to put the URLs that you suggest. I tried in the webhook section of Settings and Usage but the # doesn’t work there so I’m sure I’m wrong about that. I’m willing to try anything at this point but some additional guidance about where these webhooks would live would be most helpful.

Thank you,.
Desiree

Hi @desidem,

Could you share the site URL?

Hi!
My site is a demo (based on this tutorial: https://www.netlify.com/blog/2020/07/13/manage-subscriptions-and-protect-content-with-stripe/.) My site URL is: https://admiring-euler-fb69e1.netlify.app/

I’m not sure if that identity-signup file is not triggering OR if the code inside it isn’t right. I’m able to sign up but the roles still have to be input manually. When I sign up there’s no membership activity recorded on my Fauna or Stripe test sites. The schema.gql seems to work in Fauna but other than that no activity. Thank you!


You can also see my folder structure here and the open fauna.js file.

Right now just working with demo files until I can get it to work.
Thank you! Desiree

The easiest way to check that would be adding a console.log statement.

Since the code seems to be same as the one used in the blog post, I’m assuming it’s correct.

Are you using email based login or using social sign-in like Google in your Identity?

Hi. I’m using the email sign-in (not 3rd party). Console.log() yielded nothing. However, I have 2 theories. I’ve moved the function folder around (and deleted it too). I think when it’s completely removed/unrecognizable it doesn’t fire at all but it also doesn’t interfere with Identity sign-up/log-in. When it’s in the right spot, however, it doesn’t fire and it interferes with Identity sign-up/login because i get the message “Email not confirmed.”
When I have the functions folder at root (screenshot in previous) I get this message in the functions log:

Could you share you repo or is it exactly unchanged from that example?

This is the most recent folder view (should be unchanged from last). I deployed from local using Netlify CLI not Github.

I just put committed to Github:

Hi @desidem,

Kindly do not email our staff directly, that’s not an appropriate way to ask for support.

But coming back to your problem, the problem is because you’re using node-fetch version 3. That doesn’t support the require syntax anymore. You need to use version 2 or use the import syntax.

Hello, has there been a fix to this issue?

I have a site that is live where we use identity-signup in the exact same manner as the OP, with the difference that we are using FaunaDB. It’s been live for a long while and used to work just fine. Only recently I have noticed that anyone trying to sign up never gets an account created in our FaunaDB only in the Netlify identity.

Hey there, @Postscript-Medical :wave:

Sorry to hear you are encountering this issue! Can you please share a link to your site as well as your function name so that we can look into this further? Thank you.

Hi @hillary,

The function name is the identity-signup one and the url is: app-postscriptmedical.netlify.app.

As mentioned, my use case is the exact same as the OP. Visitors sign up on my site, Netlify identity creates a user in Netlify and the sign up webhook should be triggered, creating an entry in our FaunaDB database. I know something is wrong because: 1) The entry never gets created in Fauna and, 2) The newly created user in Netlify is missing the “owner” role.

Thank you.

Just confirming, is this happening for all signups or only OAuth-based signups? Currently, it’s a known issue that only email/password signups will trigger serverless function.s

We only have the email/password signup enabled because of that exact reason.

This is something that was working and now it isn’t. I do not know how long it has been not working as I only recently noticed entries in the identity management tab in Netlify that did not have accounts in our database.

Hey @Postscript-Medical,

This has not been working for a long time, probably from the start. Are you sure this worked before?

Hi @hrishikesh I am pretty confident it worked at some point. It might have been broken for a long time as we’ve not opened to public sign up and I have not been checking frequently. But now, we’re planning on opening for public this January coming. Is this issue something that has any level of priority to be fixed?

Hi @Postscript-Medical,

There has not been any significant progress around this. But I believe, you could use the Webhooks from identity settings that would do the job.

Hey @hrishikesh - I do appreciate the help. I did see the suggestion to use the Webhook and have tried it. For me, it did not work but I guess it is possible that I have set something up. I will try a simplified version to see what happens this time around.

When I tried it last, I kept getting 422 errors on the webhook.

Hi. Not sure if you still need help on this, but I had an issue with Fauna in which the url had been changed/updated from some original instructions.
On the GraphQL playground screen (on Fauna) there’s a URL. I assume you’re using a link, be sure it’s up to date. I think it may be: https://graphql.us.fauna.com/graphql

Hi, @desidem. Thank you for sharing that solution!

If you are someone reading after searching for a solution to this issue, please feel free to let us know below if the solution above helps you.

created a topic to follow back on this