I replaced dns records in my domain provider to Netlify, now email is not working

My site name is eightdoo.netlify.app (or custom domain www.eight.si)

On my domain provider, I see these two problems:

It says similar for SPF record (I can only embed one image in a post)

Please, can anyone help me? We are able to send emails, but we can’t receive any. I tried adding the records, like it says on my Netlify domains DNS settings, using TXT records.

But this doesn’t seem to be fixed…

Hi @Spacefox123

There’s a great Support Guide that cover migrating to Netlify DNS including configuring MX records

In short, you need to add all MX and other records (DKIM, SPF, etc.) to Netlify DNS. Ideally (as mentioned in the guide above) you would have done this prior to swtich nameservers to ensure minimal downtime.

hi @coelmay

I copied all records, but it still doesn’t seem to be working.

This is what it says on my domain provider site:

This system does not control DNS for the “eight.si” domain. Contact the person responsible for the “dns1.p08.nsone.net”,“dns2.p08.nsone.net”,“dns3.p08.nsone.net”“dns4.p08.nsone.net” nameservers and request that they update the records.

I can see the DKIM and SPF with Zoho Toolkit → Run Checks.

It is possibly a matter of waiting for records to propagate and for the system to detect them.