Hugo custom directory being ignored by netlify

My stagin site: staging–arielsdoodles.netlify.app Doesn’t show the Portfolio dropdown that is shown in my local instance whose path is (content/portfolio/_index.md)
Screenshot 2023-09-11 at 2.33.13 AM

I’m using the same HUGO_VERSION for local and on the Netlify servers.

Did you make the changes under the same branch as the Netlify site uses (probably called ‘staging’)? I do see a portfolio dropdown on the live site: https://arielsdoodles.netlify.app/

Right, the main branch (arielsdoodles.netlify.app) which is different than the staging branch:
(https://staging--arielsdoodles.netlify.app/), the staging branch has the abillity to navigate to different pages instead of everything being on the same page.

Thanks for following up, and sorry again for the hassle here; if the changes are present locally and pushed up to the staging environment, they should definitely be appearing on the live site.

Can you try a Clear cache and build site on the staging branch and let us know if that helps?

Thanks for the reply, I’ve tried the Clear cache and build site on the staging branch, and I’m still seeing the same results.

Try running hugo locally in your staging branch and see what you get. I am fairly certain you’d get the same result as on Netlify.

Nope, I ran locally and I’m getting something different, what I actually expect.
I see that on my local I have 7 Page:
Start building sites …
hugo v0.110.0+extended darwin/arm64 BuildDate=unknown

               | EN  

-------------------±----
Pages | 7
Paginator pages | 0
Non-page files | 0
Static files | 98
Processed images | 0
Aliases | 0
Sitemaps | 1
Cleaned | 0

Built in 244 ms

On staging–arielsdoodles.netlify.app it has 5 Pages and 98 Static files:

11:44:28 AM: Start building sites …
11:44:28 AM: hugo v0.110.0-e32a493b7826d02763c3b79623952e625402b168+extended linux/amd64 BuildDate=2023-01-17T12:16:09Z VendorInfo=gohugoio
11:44:29 AM: | EN
11:44:29 AM: -------------------±----
11:44:29 AM: Pages | 5
11:44:29 AM: Paginator pages | 0
11:44:29 AM: Non-page files | 0
11:44:29 AM: Static files | 98
11:44:29 AM: Processed images | 0
11:44:29 AM: Aliases | 0
11:44:29 AM: Sitemaps | 1
11:44:29 AM: Cleaned | 0

Are you sure you repo is exactly in sync with your local state? Try cloning your repo to a new directory or a device and run Hugo there to see what you get.

related
Deploy did not succeed: Deploy directory “site/site/public” does not exist - Support - Netlify Support Forums