Gatsby build failing

11:29:26 AM: Using PHP version 5.6

11:29:26 AM: Started restoring cached yarn cache

11:29:26 AM: Finished restoring cached yarn cache

11:29:27 AM: NETLIFY_YARN_WORKSPACES feature flag set

11:29:27 AM: {“type”:“error”,“data”:“Cannot find the root of your workspace - are you sure you’re currently in a workspace?”}

11:29:27 AM: No workspace detected

11:29:27 AM: Started restoring cached node modules

11:29:27 AM: Finished restoring cached node modules

11:29:27 AM: Installing NPM modules using Yarn version 1.17.0

11:29:28 AM: yarn install v1.17.0

11:29:28 AM: [1/4] Resolving packages…

11:29:29 AM: [2/4] Fetching packages…

11:30:00 AM: error gatsby@3.3.1: The engine “node” is incompatible with this module. Expected version “>=12.13.0”. Got “10.24.1”

11:30:00 AM: error Found incompatible module.

Hey this is my error from build console, I even tried to rollback package.json to some old values - still cannot past this stage of build.

Somehow, you’re using the older version of Node. Try using a minimum of Node 12 by setting Environment Variables: Manage build dependencies | Netlify Docs