Build error - yarn

I’m getting a yarn-related build error when I’m trying to bild my Gatsby site. I can yarn install and gatsby build just fine on my my computer but I get the following error when Netlify is building it "error gatsby@2.21.7: The engine “node” is incompatible with this module. Expected version “>=10.13.0”.

1 Like

hi there,

Hiya, sorry you are having trouble with your build.

This Common Issue contains a ton of useful debugging tips that can likely help you solve your problem :slight_smile:

We also recommend trying to search the forums with the build error you encountered - it’s likely your question was already asked by someone else!

If you are still having problems, please provide as much information as you can on what you have already tried, a full build log, what your build settings are, your package.json, etc. Thanks!

Ok, so I fixed the problem.
Gatsby had bumped node min version to 10.13.0 ( and the Netlify build was using node 8.17. To fix it I changed the node version in the enviroment variables for my site (

Awesome, thanks so much for sharing your solution :muscle: