Home
Support Forums

Fsevents deploy errors causing Netlify build to fail (on a Mac)

Working on a Macbook. When deploying to Netlify from it, I get the errors relating to fsevents. I’ve read that fsevents is something that’s Mac only.

Any help with this to get sorted would be very appreciated.

Domain: https://plant1.netlify.app/
Repo: here
Build log and deploy settings

5:41:52 PM: Build ready to start
5:41:54 PM: build-image version: fd3b56fcdbaad56e70919e8a4b2da9b411ec3532 (xenial)
5:41:54 PM: build-image tag: v3.10.1
5:41:54 PM: buildbot version: 84197c5d0209353d9407aac932bd185d2d2eb582
5:41:54 PM: Building without cache
5:41:54 PM: Starting to prepare the repo for build
5:41:54 PM: No cached dependencies found. Cloning fresh repo
5:41:54 PM: git clone GitHub - jd-fillmore/plant-no-1
5:41:56 PM: Preparing Git Reference refs/heads/main
5:41:57 PM: Parsing package.json dependencies
5:41:57 PM: Different publish path detected, going to use the one specified in the Netlify configuration file: ‘public’ versus ‘public/’ in the Netlify UI
5:41:57 PM: Starting build script
5:41:57 PM: Installing dependencies
5:41:57 PM: Python version set to 2.7
5:41:59 PM: v12.18.0 is already installed.
5:41:59 PM: Now using node v12.18.0 (npm v6.14.4)
5:41:59 PM: Started restoring cached build plugins
5:41:59 PM: Finished restoring cached build plugins
5:42:00 PM: Attempting ruby version 2.7.1, read from environment
5:42:01 PM: Required ruby-2.7.1 is not installed - installing.
5:42:01 PM: Searching for binary rubies, this might take some time.
5:42:01 PM: Found remote file https://rvm_io.global.ssl.fastly.net/binaries/ubuntu/16.04/x86_64/ruby-2.7.1.tar.bz2
5:42:01 PM: Checking requirements for ubuntu.
5:42:02 PM: Requirements installation successful.
5:42:02 PM: ruby-2.7.1 - #configure
5:42:02 PM: ruby-2.7.1 - #download
5:42:03 PM: ruby-2.7.1 - #validate archive
5:42:10 PM: ruby-2.7.1 - #extract
5:42:13 PM: ruby-2.7.1 - #validate binary
5:42:14 PM: ruby-2.7.1 - #setup
5:42:15 PM: ruby-2.7.1 - #gemset created /opt/buildhome/.rvm/gems/ruby-2.7.1@global
5:42:15 PM: ruby-2.7.1 - #importing gemset /opt/buildhome/.rvm/gemsets/global.gems…
5:42:16 PM: ruby-2.7.1 - #generating global wrappers…
5:42:16 PM: ruby-2.7.1 - #gemset created /opt/buildhome/.rvm/gems/ruby-2.7.1
5:42:16 PM: ruby-2.7.1 - #importing gemsetfile /opt/buildhome/.rvm/gemsets/default.gems evaluated to empty gem list
5:42:17 PM: ruby-2.7.1 - #generating default wrappers…
5:42:17 PM: Using /opt/buildhome/.rvm/gems/ruby-2.7.1
5:42:18 PM: Using ruby version 2.7.1
5:42:18 PM: Using PHP version 5.6
5:42:18 PM: Started restoring cached yarn cache
5:42:18 PM: Finished restoring cached yarn cache
5:42:19 PM: Found yarn version (1.22.10) that doesn’t match expected (1.22.4)
up to date in 0.042s
5:42:19 PM: Installing yarn at version 1.22.4
5:42:19 PM: Installing Yarn!
5:42:19 PM: > Downloading tarball…
5:42:19 PM: [1/2]: https://yarnpkg.com/downloads/1.22.4/yarn-v1.22.4.tar.gz → /tmp/yarn.tar.gz.88Bua6xlzt
5:42:19 PM: % Total % Received % Xferd Average Speed Time Time Time Current
5:42:19 PM: Dload Upload Total Spent Left Speed
5:42:19 PM: 0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0
5:42:20 PM: 0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0
5:42:20 PM: 100 79 100 79 0 0 278 0 --:–:-- --:–:-- --:–:-- 278
5:42:20 PM: 100 93 100 93 0 0 133 0 --:–:-- --:–:-- --:–:-- 133
5:42:20 PM: 100 625 100 625 0 0 647 0 --:–:-- --:–:-- --:–:-- 647
5:42:21 PM: 1 1215k 1 17755 0 0 15881 0 0:01:18 0:00:01 0:01:17 15881
5:42:21 PM: 100 1215k 100 1215k 0 0 956k 0 0:00:01 0:00:01 --:–:-- 7883k
5:42:21 PM: [2/2]: https://yarnpkg.com/downloads/1.22.4/yarn-v1.22.4.tar.gz.asc → /tmp/yarn.tar.gz.88Bua6xlzt.asc
5:42:21 PM: 100 83 100 83 0 0 890 0 --:–:-- --:–:-- --:–:-- 890
5:42:21 PM: 100 97 100 97 0 0 750 0 --:–:-- --:–:-- --:–:-- 750
5:42:21 PM: 100 629 100 629 0 0 4038 0 --:–:-- --:–:-- --:–:-- 4038
5:42:21 PM: 100 1028 100 1028 0 0 5531 0 --:–:-- --:–:-- --:–:-- 5531
5:42:21 PM: > Verifying integrity…
5:42:21 PM: gpg: Signature made Mon 09 Mar 2020 03:52:13 PM UTC using RSA key ID 69475BAA
5:42:21 PM: gpg: Good signature from “Yarn Packaging yarn@dan.cx
5:42:21 PM: gpg: WARNING: This key is not certified with a trusted signature!
5:42:21 PM: gpg: There is no indication that the signature belongs to the owner.
5:42:21 PM: Primary key fingerprint: 72EC F46A 56B4 AD39 C907 BBB7 1646 B01B 86E5 0310
5:42:21 PM: Subkey fingerprint: 6D98 490C 6F1A CDDD 448E 4595 4F77 6793 6947 5BAA
5:42:21 PM: > GPG signature looks good
5:42:21 PM: > Extracting to ~/.yarn…
5:42:21 PM: > Adding to $PATH…
5:42:21 PM: > Successfully installed Yarn 1.22.4! Please open another terminal where the yarn command will now be available.
5:42:22 PM: No yarn workspaces detected
5:42:22 PM: Started restoring cached node modules
5:42:22 PM: Finished restoring cached node modules
5:42:22 PM: Installing NPM modules using Yarn version 1.22.4
5:42:23 PM: yarn install v1.22.4
5:42:23 PM: [1/4] Resolving packages…
5:42:24 PM: [2/4] Fetching packages…
5:42:30 PM: warning url-loader@1.1.2: Invalid bin field for “url-loader”.
5:43:10 PM: info fsevents@2.3.2: The platform “linux” is incompatible with this module.
5:43:10 PM: info “fsevents@2.3.2” is an optional dependency and failed compatibility check. Excluding it from installation.
5:43:10 PM: info fsevents@1.2.13: The platform “linux” is incompatible with this module.
5:43:10 PM: info “fsevents@1.2.13” is an optional dependency and failed compatibility check. Excluding it from installation.
5:43:10 PM: error type-fest@2.5.4: The engine “node” is incompatible with this module. Expected version “>=12.20”. Got “12.18.0”
5:43:10 PM: error Found incompatible module.
5:43:10 PM: info Visit yarn pkg install for documentation about this command.
5:43:10 PM: Error during Yarn install
5:43:10 PM: Build was terminated: Build script returned non-zero exit code: 1
5:43:10 PM: Creating deploy upload records
5:43:10 PM: Failing build: Failed to build site
5:43:10 PM: Failed during stage ‘building site’: Build script returned non-zero exit code: 1
5:43:10 PM: Finished processing build request in 1m16.299128507s

The lines concerning fsevents are of an info level, so they aren’t what is causing the build to fail.

The actual error is:

5:43:10 PM: error type-fest@2.5.4: The engine “node” is incompatible with this module. Expected version “>=12.20”. Got “12.18.0”

This is telling you that this specific module expects a version >= 12.20 but the build on Netlify is running 12.18.0, which is also shown earlier in the build logs:

5:41:59 PM: v12.18.0 is already installed.
5:41:59 PM: Now using node v12.18.0 (npm v6.14.4)

You should use one of the available methods to set the specific version of node that your build requires, ensuring it is >= 12.20

1 Like

Thank you very much!