Error on deploy: Unsupported platform for fsevents@2.3.2

Hi this is for https://nigelyonsvideo.netlify.app/, it’s failing as soon as it starts to install NPM.

8:50:17 PM: Build ready to start
8:50:26 PM: build-image version: d7b3dbfb0846505993c9a131894d1858074c90b4 (focal)
8:50:26 PM: build-image tag: v4.10.1
8:50:26 PM: buildbot version: f7070267d9348624fde5c2d682aa32cc686742a6
8:50:26 PM: Building without cache
8:50:26 PM: Starting to prepare the repo for build
8:50:26 PM: No cached dependencies found. Cloning fresh repo
8:50:26 PM: git clone https://github.com/Nitrodouglas/nigelyons.video
8:50:26 PM: Preparing Git Reference refs/heads/main
8:50:27 PM: Parsing package.json dependencies
8:50:27 PM: Different build dir detected, going to use the one specified in the Netlify configuration file: '' versus '/' in the Netlify UI
8:50:27 PM: Starting build script
8:50:27 PM: Installing dependencies
8:50:27 PM: Python version set to 2.7
8:50:28 PM: Downloading and installing node v16.17.0...
8:50:28 PM: Downloading https://nodejs.org/dist/v16.17.0/node-v16.17.0-linux-x64.tar.xz...
8:50:29 PM: Computing checksum with sha256sum
8:50:29 PM: Checksums matched!
8:50:30 PM: Now using node v16.17.0 (npm v8.15.0)
8:50:30 PM: Started restoring cached build plugins
8:50:30 PM: Finished restoring cached build plugins
8:50:31 PM: Attempting ruby version 2.7.2, read from environment
8:50:31 PM: Using ruby version 2.7.2
8:50:31 PM: Using PHP version 8.0
8:50:32 PM: No npm workspaces detected
8:50:32 PM: Started restoring cached node modules
8:50:32 PM: Finished restoring cached node modules
8:50:32 PM: Installing NPM modules using NPM version 8.15.0
8:50:32 PM: npm WARN config tmp This setting is no longer used.  npm stores temporary files in a special
8:50:32 PM: npm WARN config location in the cache, and they are managed by
8:50:32 PM: npm WARN config     [`cacache`](http://npm.im/cacache).
8:50:32 PM: npm WARN config tmp This setting is no longer used.  npm stores temporary files in a special
8:50:32 PM: npm WARN config location in the cache, and they are managed by
8:50:32 PM: npm WARN config     [`cacache`](http://npm.im/cacache).
8:50:32 PM: npm ERR! code EBADPLATFORM
8:50:32 PM: npm ERR! notsup Unsupported platform for fsevents@2.3.2: wanted {"os":"darwin"} (current: {"os":"linux","arch":"x64"})
8:50:32 PM: npm ERR! notsup Valid OS:    darwin
8:50:32 PM: Creating deploy upload records
8:50:32 PM: npm ERR! notsup Valid Arch:  undefined
8:50:32 PM: npm ERR! notsup Actual OS:   linux
8:50:32 PM: npm ERR! notsup Actual Arch: x64
8:50:32 PM: npm ERR! A complete log of this run can be found in:
8:50:32 PM: npm ERR!     /opt/buildhome/.npm/_logs/2022-08-24T00_50_32_728Z-debug-0.log
8:50:33 PM: Failed during stage 'building site': Build script returned non-zero exit code: 1 (https://ntl.fyi/exit-code-1)
8:50:32 PM: Error during NPM install
8:50:32 PM: Build was terminated: Build script returned non-zero exit code: 1
8:50:33 PM: Failing build: Failed to build site
8:50:33 PM: Finished processing build request in 7.286875581s

Hi @Nitrodouglas

The problem is here:

8:50:32 PM: npm ERR! code EBADPLATFORM
8:50:32 PM: npm ERR! notsup Unsupported platform for fsevents@2.3.2: wanted {"os":"darwin"} (current: {"os":"linux","arch":"x64"})
8:50:32 PM: npm ERR! notsup Valid OS:    darwin
8:50:32 PM: Creating deploy upload records
8:50:32 PM: npm ERR! notsup Valid Arch:  undefined
8:50:32 PM: npm ERR! notsup Actual OS:   linux
8:50:32 PM: npm ERR! notsup Actual Arch: x64

Take a look at this stack overflow article and see if it helps: node.js - npm install error (code EBADPLATFORM) - Stack Overflow