Forms deleted, new site still forms not recognized

Site URL:

There are 4 different forms.
The simplest is in every page. Every form used to work at some point.

I had previously other site, and forms were working. Recognized, except for some fields.
I changed the implementation so everything is static html. It still didn’t recognized the new fields.
Deleted the forms, and everything stopped working. I attempted to change form names, methods, nothing worked. It doesn’t recognize new forms, or any form whatsoever. I decided to erase old site, and create a new one, but still no form is recognized.

In any case what should I do to get the forms recognized ? They are plain HTML, no JS. New site.

@fbruening Try running through the steps/checks in the Forms Debugging Support Guide:

Yes, I did that. I don’t know what else can be wrong. Like I said they used to work, only after deleting the endpoints on the old site it stopped working. I changed names, and still. I created a new site, and still not working.

@fbruening What ‘endpoints’?

Were these forms previously configured to work with Netlify Forms, or with something else?

You don’t create/delete endpoints for Netlify Forms.

Your site/forms also doesn’t seem to be “plain HTML, no JS”, maybe you should start testing by making an actual plain HTML form and stepping through that.

I mean ‘the forms’ with endpoints. You can delete them in the UI.
They used to work until I deleted them. Not sure why now they are not working. Changed name, changed site.
The hidden input is correctly updated with the form name, so I suppose they are recognized.

There shouldn’t be any mystery.

You can tell if Netlify has detected forms in your build output by checking the build log.

1 Like

Solved it. Seems like forms will only be recognized when they don’t have a method attribute, or event handlers. After deploy and forms being recognized I could revert the changes, and the forms would work with AJAX like previously.

1 Like