Form submissions do not work at all. Tried everything

Hi there.

I added a form to my site ( and it does not work. Sorry for this silly issue explanation, but it just does not work at all.

  • Just a 404 (even though I have a success page setup, that even is publicly available).
  • No submissions show up in the admin UI.
  • There is not even a single hint in the deploy logs about that the form has even been recognized (should forms appear in the build log?)

I followed every single guideline of yours and read a lot of community forums and tried everything that is mentioned in those docs, trouble shooting guides and community answers.

No single clue anywhere. This is a very frustrating DX.

Some things to help you debugging this issue:

Please, I tried everything the last couple of hours. This is my final desperate ask for help before I will start using a different solution.

I really want to give you my money (do forms even work in a free plan?), but if this does not work out soon I will spend it somewhere else.


Moin Thomas, sorry you are having trouble getting your forms to work.

Lets run through some checks! i bet we can get this working.

I realize you said you had read some guides already, but this is the best guide to assist with the problems you are experiencing. did you read it? If yes, cool, i just want to check.

Forms absolutely do work on the starter tier, with up to 100 submissions per month.

One more sanity check: when you are testing your form, are you using data such as "
or similar? because those will definitely get filtered out by the spam checker.

Also, I see that your name="Kontakt" etc attributes are uppercase. I am not 100% sure whether this makes a difference, but normally people lowercase everything. Can you try changing all the name attributes to lowercase just to be sure?

I might also suggest you simplify the form so we can get it working (for example, take out the spamcheck honeypot field - we can always put it back in once we figure out what is causing the problem.

Can you try these things and let us know? we definitely want to help you figure it out.

i’ve also confirmed that your forms should be working in deploy previews.

does the form show up in your netlify site dashboard? lets start there maybe.

I started out with lower cased name attributes and without a honey pot field as you can see in the git commit log.

Since the form did not work from the beginning I do not think reverting those changes will fix anything.

No, there are no forms appearing in the dashboard. Under “Forms” I only see advertisement for the feature, but no forms or any submissions.

I am testing the forms with my regular email address and not a test mail.

As I already said I tried everything. I am a web developer for over 20 years now. I ask for help after I try everything. Not before. So, the issue is somewhere non obvious. Otherwise I would have solved it myself.

Could you please check back with your dev ops team if there is anything they can tell us?


  • Should there be log entries in the build logs if a form gets recognized? There is nothing that hints about forms during the build.

I strongly recommend to add some more logging or debugging around forms in the build step.

Thanks for the help.

okay, well that’s some information then, if you form isn’t in the dashboard that explains why you’re not seeing submissions. My first concern would be to understand why your form isn’t getting picked up at all.

I am assuming this is your first netlify form?

Did you deploy with the basic form in place and then check the dashboard?

Of course I don’t know your personal background or experience level (nor you mine, I started working as a front end engineer in 1999…) so we always start at the beginning with all of our customers. If that feels like a process you don’t have time for, that’s a decision I can’t make for you, but of course I hope you stick around so we can figure it out.

1 Like

Yes I started with a basic form and checked the dashboard all the time. The form never showed up.

Will try again with a single field form tomorrow.

Would be great to get feedback from the dev ops team. Something needs to be in the logs.

Thanks so far for the help.

great. lets get a simple form working and we’ll take it from there. I’ll ask the person who knows most about forms to check in on this thread for us. I bet we can get it working.

Hello @tvdeyen, I took a look at your git logs and do show that you are using the attributes netlify and netlify-honeypot. However, since your form starts out as a .vue file, you’ll probably want to use the data-netlify and data-netlify-honeypot variant. This is because most JS frameworks like React or VueJS will parse/swallow element attributes as props. Could you give that a try?

Actually, after re-reading your logs, I do see that you’ve tried the data prefix. I’ll take another look to see what maybe is the issue.

It look likes the issue you are running into is due to how Nuxt works under the hood. Someone posted about this here. They mention that even if Nuxt does build down to html, netlify forms can still be missed by our buildbot since attributes like the ones we suggest only get added via javascript upon loading the page. If you view your built html directly (via a text/code editor), you’ll find that they do not actually contain your form. Can you try creating an HTML version of your form as the post suggests and see if that helps?

Thanks, Dennis.

This was a good hint. But the solution was not as mentioned in the article, but to change the Nuxt mode in the nuxt.config.js to universal. Somehow this was still set to spa and in that mode there will be no static HTML files generated, even if one uses the yarn generate command. A bit confusing.

Now that I changed the mode to universal static html files get generating and the <form> appears in the html output.

Thanks for the great help and being patient with me.

hey @tvdeyen - super glad we were able to work together to figure this out and you now have a working form :tada: :partying_face:

I’ve made a note on what you mentioned about the nuxt mode. that is confusing indeed.

viele gruesse nach HH (ich bin dort aufgewachsen, komme urspruenglich aus England, wohne jetzt in Portland, Oregon)