Form not being detected

  • Netlify site name:
  • page where form is located: (generated by hugo)

This is a one-page site, so the only form is on the only page of the site.

I have been through the debugging guide at [Support Guide] Form problems, form debugging, 404 when submitting and, as far as I can tell, all the issues have been handled correctly (I’m sure that something isn’t quite right, but I sure can’t find it!).

The form tag is as follows:
<form name="online-order" netlify-data="true" netlify-honeypot="bf" method="post" action="/thankyou.html" subject="sweetFrog Order">

I have verified that all input fields have a name attribute, and that all are unique within the form. The only other thing I can think of is that this form has several blocks with style set as “display:none”, which appear after the user selects the number of items to order (i.e., if they select 3 items, they see three blocks of choices for ordering). These blocks work correctly, but I don’t know if the JS could be affecting the deploy.

I do have another site with a simple contact form, which worked instantly on deploy.

Any guidance much appreciated!


It’s data-netlify="true" and not the other way round.

Thank you for the correction. I had originally simply used the “netlify” attribute, which did not work. I have made the correction you suggest, but, as with the “netlify” attribute, it still doesn’t work.

Kindly share the link to the webpage.

Looks like it’s here:

Oh sorry, I meant link to the repo. :sweat_smile:

1 Like

Correct, @kylesloper - it is


Oh, I see. The repo is at GitHub - fayettevillesf/orderform

1 Like

BTW, the order form is in layouts/partials/order.html

1 Like

This is strange. The setup looks fine, as in the form should at least have got detected. Trying to figure it out.

Got it. It was because your action attribute had a absolute URL. Netlify forms doesn’t support it. In your config.toml, change canonifyurls = true to canonifyurls = false (or remove it entirely, it defaults to false).

Got this in my deploy log:

9:51:24 PM: Creating deploy upload records
9:51:25 PM: Starting post processing
9:51:25 PM: Post processing - HTML
9:51:25 PM: Processing form - online-order
9:51:25 PM: Detected form fields:
9:51:25 PM:  - NAME
9:51:25 PM:  - EMAIL
9:51:25 PM:  - num_cups
9:51:25 PM:  - SIZE_YOGURT_CUP_1
9:51:25 PM:  - FLAVORS_OF_YOGURT_CUP_1[]
9:51:25 PM:  - TOPPINGS_CUP_1[]
9:51:25 PM:  - bf
9:51:25 PM:  - SIZE_YOGURT_CUP_2
9:51:25 PM:  - FLAVORS_OF_YOGURT_CUP_2[]
9:51:25 PM:  - TOPPINGS_CUP_2[]
9:51:25 PM:  - SIZE_YOGURT_CUP_3[]
9:51:25 PM:  - FLAVORS_OF_YOGURT_CUP_3[]
9:51:25 PM:  - TOPPINGS_CUP_3[]
9:51:25 PM:  - SIZE_YOGURT_CUP_4
9:51:26 PM:  - FLAVORS_OF_YOGURT_CUP_4[]
9:51:26 PM:  - TOPPINGS_CUP_4[]
9:51:26 PM:  - SIZE_YOGURT_CUP_5
9:51:26 PM:  - FLAVORS_OF_YOGURT_CUP_5[]
9:51:26 PM:  - TOPPINGS_CUP_5[]
9:51:26 PM:  - SIZE_YOGURT_CUP_6
9:51:26 PM:  - FLAVORS_OF_YOGURT_CUP_6[]
9:51:26 PM:  - TOPPINGS_CUP_6[]
9:51:26 PM:  - SIZE_YOGURT_CUP_7
9:51:26 PM:  - FLAVORS_OF_YOGURT_CUP_7[]
9:51:26 PM:  - TOPPINGS_CUP_7[]
9:51:26 PM:  - SIZE_YOGURT_CUP_8
9:51:26 PM:  - FLAVORS_OF_YOGURT_CUP_8[]
9:51:26 PM:  - TOPPINGS_CUP_8[]
9:51:26 PM:  - Using_Gift_Card
9:51:26 PM:  - GCnumber
9:51:26 PM:  - MESSAGE
9:51:26 PM:  - ORDERNUM
9:51:26 PM:  - ccnum
9:51:26 PM:  - ccCVV
9:51:26 PM:  - ccexp
9:51:26 PM: Post processing - header rules
9:51:26 PM: Post processing - redirect rules
9:51:26 PM: Post processing done
9:51:26 PM: Site is live ✨

I haven’t tested if the form is working fine though.

Sorry - had to go out for a bit.

I just tried it and netlify discovered the form, and after submitting it went to the custom thank you page, just as it should.

Thank you so much for your help!