Failed Validating Rendering Engines - during gatsby build

Hello, my netlify site name is

The build fails with the below error

failed Validating Rendering Engines - 3.298s
4:46:32 PM: error Built Rendering Engines failed validation.
4:46:32 PM: Please open an issue with a reproduction at Sign in to GitHub Β· GitHub for more help.
4:46:32 PM:
4:46:32 PM:
4:46:32 PM: Error: Worker exited before finishing task
4:46:32 PM:
4:46:32 PM: - index.js:205 ChildProcess.
4:46:32 PM: [repo]/[gatsby-worker]/dist/index.js:205:41
4:46:32 PM:
4:46:32 PM:
4:46:32 PM: not finished Running gatsby.IMAGE_CDN jobs - 2155.590s
4:46:33 PM: ​
4:46:33 PM: β€œbuild.command” failed
4:46:33 PM: ────────────────────────────────────────────────────────────────
4:46:33 PM: ​
4:46:33 PM: Error message
4:46:33 PM: Command failed with exit code 1: gatsby build (Search results for '"non-zero exit code: 1"' - Netlify Support Forums)
4:46:33 PM: ​
4:46:33 PM: Error location
4:46:33 PM: In Build command from Netlify app:
4:46:33 PM: gatsby build
4:46:33 PM: ​
4:46:33 PM: Resolved config
4:46:33 PM: build:
4:46:33 PM: base: /opt/build/repo
4:46:33 PM: command: gatsby build
4:46:33 PM: commandOrigin: ui
4:46:33 PM: publish: /opt/build/repo/public
4:46:33 PM: publishOrigin: ui
4:46:34 PM: Failed during stage β€œbuilding site”: Build script returned non-zero exit code: 2
4:46:34 PM: Build failed due to a user error: Build script returned non-zero exit code: 2
4:46:34 PM: Failing build: Failed to build site

Have tried all the steps mentioned in the article but no help Unexpected Rendering Engines validation failure (Gatsby v4) Β· Issue #34293 Β· gatsbyjs/gatsby Β· GitHub

Any other directions would be helpful. Below is the full build log

Thanks in Advance! :pray:

If you’re using image CDN, can you try not using it to see if it helps?

1 Like

Hello Hrishikesh!
Thank you for your suggestion, FYI I have not enabled image_cdn ,
Nevertheless, I have tried to set the configuration in netlify.toml file with below snippet


No luck yet, still the same error. Do you know how to confirm if the configuration is set properly? Is there any way to check if the netlify.toml file is read properly?

I have added it in the root folder as mentioned in

This is also reported as open issue in github

tried all suggestion of downgrading the gatsby-source-wordpress plugin to various version mentioned in the issue. No luck! :frowning_face:

Hey there,

Thanks for following up, and apologies again for the hassle! Are you seeing this error in local builds as well? If so, for the next steps, you’ll want to:

  1. In your node_modules directory, navigate to: node_modules/gatsby/dist/utils/validate-engines/index.js.
  2. Change silent: true to silent: false.
  3. Re-run the build

This won’t resolve the build errors but should output a more actionable error message that points to the root cause of the failed builds. Please reach out with any questions!

Hello @marcus.little ,

We have cleared the webpages from the test site and started setting the pages one by one, (built the site from scratch) thus we eliminated the issue. So this can be closed. Thank you for the followup. :slight_smile:

That’s great to hear - thanks for following up and confirming!