Failed Building production JavaScript and CSS bundles - Build script returned non-zero exit code: 1

Sitename: practical-johnson-afe90e
Deploy logs:

3:19:46 AM: Build ready to start
3:19:48 AM: build-image version: 3031d4c9e432fd7016f6279fc9ad706f9205d845
3:19:48 AM: build-image tag: v3.3.17
3:19:48 AM: buildbot version: 1f35b3abd6e2bf5230d8edf68072840fdec1513f
3:19:48 AM: Fetching cached dependencies
3:19:48 AM: Failed to fetch cache, continuing with build
3:19:48 AM: Starting to prepare the repo for build
3:19:49 AM: No cached dependencies found. Cloning fresh repo
3:19:49 AM: git clone https://github.com/vlajke/gatsby-test
3:19:50 AM: Preparing Git Reference refs/heads/master
3:19:51 AM: Different publish path detected, going to use the one specified in the Netlify configuration file: 'public' versus 'public/' in the Netlify UI
3:19:51 AM: Starting build script
3:19:52 AM: Installing dependencies
3:19:52 AM: Python version set to 2.7
3:19:53 AM: v12.18.0 is already installed.
3:19:54 AM: Now using node v12.18.0 (npm v6.14.4)
3:19:54 AM: Started restoring cached build plugins
3:19:54 AM: Finished restoring cached build plugins
3:19:54 AM: Attempting ruby version 2.7.1, read from environment
3:19:56 AM: Using ruby version 2.7.1
3:19:57 AM: Using PHP version 5.6
3:19:57 AM: 5.2 is already installed.
3:19:57 AM: Using Swift version 5.2
3:19:57 AM: Started restoring cached node modules
3:19:57 AM: Finished restoring cached node modules
3:19:57 AM: Installing NPM modules using NPM version 6.14.4
3:20:49 AM: > sharp@0.23.4 install /opt/build/repo/node_modules/sharp
3:20:49 AM: > (node install/libvips && node install/dll-copy && prebuild-install) || (node-gyp rebuild && node install/dll-copy)
3:20:49 AM: info sharp Downloading https://github.com/lovell/sharp-libvips/releases/download/v8.8.1/libvips-8.8.1-linux-x64.tar.gz
3:20:51 AM: > node-sass@4.13.1 install /opt/build/repo/node_modules/node-sass
3:20:51 AM: > node scripts/install.js
3:20:52 AM: Downloading binary from https://github.com/sass/node-sass/releases/download/v4.13.1/linux-x64-72_binding.node
3:20:53 AM: Download complete
3:20:53 AM: Binary saved to /opt/build/repo/node_modules/node-sass/vendor/linux-x64-72/binding.node
3:20:53 AM: Caching binary to /opt/buildhome/.npm/node-sass/4.13.1/linux-x64-72_binding.node
3:20:53 AM: > core-js@2.6.11 postinstall /opt/build/repo/node_modules/core-js
3:20:53 AM: > node -e "try{require('./postinstall')}catch(e){}"
3:20:54 AM: > gatsby-telemetry@1.1.51 postinstall /opt/build/repo/node_modules/gatsby-telemetry
3:20:54 AM: > node src/postinstall.js || true
3:20:54 AM: > cwebp-bin@5.1.0 postinstall /opt/build/repo/node_modules/cwebp-bin
3:20:54 AM: > node lib/install.js
3:20:55 AM:   ✔ cwebp pre-build test passed successfully
3:20:55 AM: > mozjpeg@6.0.1 postinstall /opt/build/repo/node_modules/mozjpeg
3:20:55 AM: > node lib/install.js
3:20:56 AM:   ✔ mozjpeg pre-build test passed successfully
3:20:56 AM: > pngquant-bin@5.0.2 postinstall /opt/build/repo/node_modules/pngquant-bin
3:20:56 AM: > node lib/install.js
3:20:56 AM:   ✔ pngquant pre-build test passed successfully
3:20:56 AM: > gatsby-cli@2.10.2 postinstall /opt/build/repo/node_modules/gatsby/node_modules/gatsby-cli
3:20:56 AM: > node scripts/postinstall.js
3:20:56 AM: > gatsby@2.19.32 postinstall /opt/build/repo/node_modules/gatsby
3:20:56 AM: > node scripts/postinstall.js
3:20:57 AM: > node-sass@4.13.1 postinstall /opt/build/repo/node_modules/node-sass
3:20:57 AM: > node scripts/build.js
3:20:57 AM: Binary found at /opt/build/repo/node_modules/node-sass/vendor/linux-x64-72/binding.node
3:20:57 AM: Testing binary
3:20:57 AM: Binary is fine
3:21:00 AM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.11 (node_modules/fsevents):
3:21:00 AM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.11: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
3:21:00 AM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.2 (node_modules/chokidar/node_modules/fsevents):
3:21:00 AM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.2: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
3:21:00 AM: added 2157 packages from 960 contributors and audited 2235 packages in 62.002s
3:21:02 AM: 55 packages are looking for funding
3:21:02 AM:   run `npm fund` for details
3:21:02 AM: found 92 vulnerabilities (79 low, 3 moderate, 10 high)
3:21:02 AM:   run `npm audit fix` to fix them, or `npm audit` for details
3:21:02 AM: NPM modules installed
3:21:03 AM: Started restoring cached go cache
3:21:03 AM: Finished restoring cached go cache
3:21:03 AM: go version go1.14.4 linux/amd64
3:21:03 AM: go version go1.14.4 linux/amd64
3:21:03 AM: Installing missing commands
3:21:03 AM: Verify run directory
3:21:04 AM: ​
3:21:04 AM: ┌─────────────────────────────┐
3:21:04 AM: │        Netlify Build        │
3:21:04 AM: └─────────────────────────────┘
3:21:04 AM: ​
3:21:04 AM: ❯ Version
3:21:04 AM:   @netlify/build 2.0.10
3:21:04 AM: ​
3:21:04 AM: ❯ Flags
3:21:04 AM:   deployId: 5ef2aa32842590021056f029
3:21:04 AM:   mode: buildbot
3:21:04 AM: ​
3:21:04 AM: ❯ Current directory
3:21:04 AM:   /opt/build/repo
3:21:04 AM: ​
3:21:04 AM: ❯ Config file
3:21:04 AM:   No config file was defined: using default values.
3:21:04 AM: ​
3:21:04 AM: ❯ Context
3:21:04 AM:   production
3:21:04 AM: ​
3:21:04 AM: ┌────────────────────────────────┐
3:21:04 AM: │ 1. Build command from settings │
3:21:04 AM: └────────────────────────────────┘
3:21:04 AM: ​
3:21:04 AM: $ gatsby build
3:21:07 AM: success open and validate gatsby-configs - 0.034s
3:21:08 AM: success load plugins - 1.044s
3:21:08 AM: success onPreInit - 0.013s
3:21:08 AM: success delete html and css files from previous builds - 0.014s
3:21:08 AM: success initialize cache - 0.010s
3:21:08 AM: success copy gatsby files - 0.042s
3:21:08 AM: success onPreBootstrap - 0.006s
3:21:08 AM: success createSchemaCustomization - 0.013s
3:21:10 AM:  -> wordpress__acf_options fetched : 1
3:21:11 AM:  -> wordpress__acf_posts fetched : 1
3:21:13 AM:  -> wordpress__acf_pages fetched : 24
3:21:16 AM:  -> wordpress__acf_media fetched : 94
3:21:16 AM:  -> wordpress__acf_blocks fetched : 0
3:21:17 AM:  -> wordpress__acf_events_post_type fetched : 3
3:21:17 AM:  -> wordpress__acf_resources_post_type fetched : 1
3:21:18 AM:  -> wordpress__acf_categories fetched : 1
3:21:18 AM:  -> wordpress__acf_tags fetched : 0
3:21:19 AM:  -> wordpress__acf_comments fetched : 0
3:21:19 AM:  -> wordpress__acf_users fetched : 1
3:21:20 AM: 
3:21:20 AM: Path: /wp-json/yoast/v1/indexation/posts?per_page=100&page=1
3:21:20 AM: The server response was "404 Not Found"
3:21:20 AM: Inner exception message: "No route was found matching the URL and request method"
3:21:21 AM:  -> wordpress__wp_api_menus_menus_items fetched : 1
3:21:21 AM:  -> wordpress__wp_api_menus_menus_items fetched : 1
3:21:21 AM:  -> wordpress__wp_api_menus_menus fetched : 2
3:21:22 AM:  -> wordpress__wp_api_menus_menu_locations fetched : 1
3:21:22 AM:  -> wordpress__POST fetched : 1
3:21:24 AM:  -> wordpress__PAGE fetched : 24
3:21:30 AM:  -> wordpress__wp_media fetched : 863
3:21:31 AM:  -> wordpress__wp_events_post_type fetched : 3
3:21:31 AM:  -> wordpress__wp_resources_post_type fetched : 1
3:21:32 AM:  -> wordpress__CATEGORY fetched : 30
3:21:34 AM: error (node:1435) [DEP0066] DeprecationWarning: OutgoingMessage.prototype._headers is deprecated
3:21:52 AM: success source and transform nodes - 44.078s
3:21:53 AM: warning Multiple node fields resolve to the same GraphQL field `wordpress__wp_resources_post_type.yoast_meta.content` - [`content`, `content___NODE`]. Gatsby will use `content___NODE`.
3:21:53 AM: warning Multiple node fields resolve to the same GraphQL field `wordpress__wp_resources_post_type.yoast_json_ld.wordpress__graph.url` - [`url`, `url___NODE`]. Gatsby will use `url___NODE`.
3:21:53 AM: warning Multiple node fields resolve to the same GraphQL field `wordpress__wp_events_post_type.yoast_meta.content` - [`content`, `content___NODE`]. Gatsby will use `content___NODE`.
3:21:53 AM: warning Multiple node fields resolve to the same GraphQL field `wordpress__wp_events_post_type.yoast_json_ld.wordpress__graph.url` - [`url`, `url___NODE`]. Gatsby will use `url___NODE`.
3:21:53 AM: warning Multiple node fields resolve to the same GraphQL field `wordpress__wp_media.yoast_meta.content` - [`content`, `content___NODE`]. Gatsby will use `content___NODE`.
3:21:53 AM: warning Multiple node fields resolve to the same GraphQL field `wordpress__wp_media.yoast_json_ld.wordpress__graph.url` - [`url`, `url___NODE`]. Gatsby will use `url___NODE`.
3:21:53 AM: warning Multiple node fields resolve to the same GraphQL field `wordpress__wp_media.guid` - [`guid___NODE`, `guid`]. Gatsby will use `guid___NODE`.
3:21:53 AM: warning Multiple node fields resolve to the same GraphQL field `wordpress__PAGE.yoast_meta.content` - [`content`, `content___NODE`]. Gatsby will use `content___NODE`.
3:21:53 AM: warning Multiple node fields resolve to the same GraphQL field `wordpress__PAGE.yoast_json_ld.wordpress__graph.url` - [`url`, `url___NODE`]. Gatsby will use `url___NODE`.
3:21:53 AM: warning Multiple node fields resolve to the same GraphQL field `wordpress__POST.yoast_meta.content` - [`content`, `content___NODE`]. Gatsby will use `content___NODE`.
3:21:53 AM: warning Multiple node fields resolve to the same GraphQL field `wordpress__POST.yoast_json_ld.wordpress__graph.url` - [`url`, `url___NODE`]. Gatsby will use `url___NODE`.
3:21:56 AM: warning There are conflicting field types in your data.
3:21:56 AM: If you have explicitly defined a type for those fields, you can safely ignore this warning message.
3:21:56 AM: Otherwise, Gatsby will omit those fields from the GraphQL schema.
3:21:56 AM: If you know all field types in advance, the best strategy is to explicitly define them with the `createTypes` action, and skip inference with the `@dontInfer` directive.
3:21:56 AM: See https://www.gatsbyjs.org/docs/actions/#createTypes
3:21:56 AM: wordpress__wp_resources_post_type.yoast_json_ld.wordpress_@graph.potentialAction.target:
3:21:56 AM:  - type: array
3:21:56 AM:    value: [ ..., 'https://werockthespectrumcincinnati.wrtsfranchise.com/resource/agnesa-papazyan-psyd/', ... ]
3:21:56 AM:  - type: string
3:21:56 AM:    value: 'https://werockthespectrumcincinnati.wrtsfranchise.com/?s={search_term_string}'
3:21:56 AM: wordpress__wp_events_post_type.yoast_json_ld.wordpress_@graph.potentialAction.target:
3:21:56 AM:  - type: array
3:21:56 AM:    value: [ ..., 'https://werockthespectrumcincinnati.wrtsfranchise.com/event/we-rock-the-spectrums-2019-rockin-resource-fair/', ... ]
3:21:56 AM:  - type: string
3:21:56 AM:    value: 'https://werockthespectrumcincinnati.wrtsfranchise.com/?s={search_term_string}'
3:21:56 AM: wordpress__wp_media.yoast_json_ld.wordpress_@graph.potentialAction.target:
3:21:56 AM:  - type: array
3:21:56 AM:    value: [ ..., 'https://werockthespectrumcincinnati.wrtsfranchise.com/wp-content/uploads/2020/06/Gym-Logo-Transparent.png', ... ]
3:21:56 AM:  - type: string
3:21:56 AM:    value: 'https://werockthespectrumcincinnati.wrtsfranchise.com/?s={search_term_string}'
3:21:56 AM: wordpress__wp_media.media_details.image_meta.orientation:
3:21:56 AM:  - type: number
3:21:56 AM:    value: 1
3:21:56 AM:  - type: string
3:21:56 AM:    value: '0'
3:21:56 AM: wordpress__PAGE.yoast_json_ld.wordpress_@graph.potentialAction.target:
3:21:56 AM:  - type: array
3:21:56 AM:    value: [ ..., 'https://werockthespectrumcincinnati.wrtsfranchise.com/rock-shop/', ... ]
3:21:56 AM:  - type: string
3:21:56 AM:    value: 'https://werockthespectrumcincinnati.wrtsfranchise.com/?s={search_term_string}'
3:21:56 AM: wordpress__POST.yoast_json_ld.wordpress_@graph.wordpress_@type:
3:21:56 AM:  - type: array
3:21:56 AM:    value: [ ..., 'Person', ... ]
3:21:56 AM:  - type: string
3:21:56 AM:    value: 'WebSite'
3:21:56 AM: wordpress__POST.yoast_json_ld.wordpress_@graph.potentialAction.target:
3:21:56 AM:  - type: array
3:21:56 AM:    value: [ ..., 'https://werockthespectrumcincinnati.wrtsfranchise.com/coming-soon/', ... ]
3:21:56 AM:  - type: string
3:21:56 AM:    value: 'https://werockthespectrumcincinnati.wrtsfranchise.com/?s={search_term_string}'
3:21:56 AM: success building schema - 3.594s
3:21:56 AM: success createPages - 0.243s
3:21:56 AM: success createPagesStatefully - 0.100s
3:21:56 AM: success onPreExtractQueries - 0.001s
3:21:56 AM: success update schema - 0.073s
3:21:57 AM: success extract queries from components - 1.002s
3:21:57 AM: warning The GraphQL query in the non-page component "/opt/build/repo/src/templates/nonprofit.js" will not be run.
3:21:57 AM: Exported queries are only executed for Page components. It's possible you're
3:21:57 AM: trying to create pages in your gatsby-node.js and that's failing for somereason.
3:21:57 AM: If the failing component(s) is a regular component and not intended to be a page
3:21:57 AM: component, you generally want to use a <StaticQuery> (https://gatsbyjs.org/docs/static-query)
3:21:57 AM: instead of exporting a page query.
3:21:57 AM: If you're more experienced with GraphQL, you can also export GraphQLfragments from components and compose the fragments in the Page component
3:21:57 AM: query and pass data down into the child component — http://graphql.org/learn/queries/#fragments
3:21:57 AM: success write out requires - 0.006s
3:21:57 AM: success write out redirect data - 0.001s
3:21:57 AM: success Build manifest and related icons - 0.128s
3:21:57 AM: success onPostBootstrap - 0.130s
3:21:57 AM: ⠀
3:21:57 AM: info bootstrap finished - 53.081 s
3:21:57 AM: ⠀
3:21:58 AM: warning
3:21:58 AM:                  The requested width "400px" for a resolutions field for
3:21:58 AM:                  the file /opt/build/repo/.cache/gatsby-source-filesystem/96274bfab1abf3a9de26d43e98fb0a5c/Gym-Logo-Transparent.png
3:21:58 AM:                  was larger than the actual image width of 360px!
3:21:58 AM:                  If possible, replace the current image with a larger one.
3:21:58 AM: warning
3:21:58 AM:                  The requested width "400px" for a resolutions field for
3:21:58 AM:                  the file /opt/build/repo/.cache/gatsby-source-filesystem/3f8615699e8df41fba81a14f28b562e7/logomap-1.png
3:21:58 AM:                  was larger than the actual image width of 140px!
3:21:58 AM:                  If possible, replace the current image with a larger one.
3:21:58 AM: warning
3:21:58 AM:                  The requested width "400px" for a resolutions field for
3:21:58 AM:                  the file /opt/build/repo/.cache/gatsby-source-filesystem/91bf758254433fcdc1dda25bf1a770b4/1_23.jpg
3:21:58 AM:                  was larger than the actual image width of 230px!
3:21:58 AM:                  If possible, replace the current image with a larger one.
3:21:58 AM: warning
3:21:58 AM:                  The requested width "400px" for a resolutions field for
3:21:58 AM:                  the file /opt/build/repo/.cache/gatsby-source-filesystem/c1b873cf615a700351b4d60cfab2d0c8/1_25.jpg
3:21:58 AM:                  was larger than the actual image width of 230px!
3:21:58 AM:                  If possible, replace the current image with a larger one.
3:22:00 AM: failed Building production JavaScript and CSS bundles - 1.893s
3:22:00 AM: error Generating JavaScript bundles failed
3:22:00 AM: [BABEL] /opt/build/repo/.cache/production-app.js: Cannot find module '@babel/compat-data/corejs3-shipped-proposals'
3:22:00 AM: Require stack:
3:22:00 AM: - /opt/build/repo/node_modules/@babel/preset-env/lib/polyfills/corejs3/usage-plugin.js
3:22:00 AM: - /opt/build/repo/node_modules/@babel/preset-env/lib/index.js
3:22:00 AM: - /opt/build/repo/node_modules/@babel/core/lib/config/files/plugins.js
3:22:00 AM: - /opt/build/repo/node_modules/@babel/core/lib/config/files/index.js
3:22:00 AM: - /opt/build/repo/node_modules/@babel/core/lib/index.js
3:22:00 AM: - /opt/build/repo/node_modules/babel-loader/lib/index.js
3:22:00 AM: - /opt/build/repo/node_modules/gatsby/dist/utils/babel-loader.js
3:22:00 AM: - /opt/build/repo/node_modules/loader-runner/lib/loadLoader.js
3:22:00 AM: - /opt/build/repo/node_modules/loader-runner/lib/LoaderRunner.js
3:22:00 AM: - /opt/build/repo/node_modules/webpack/lib/NormalModule.js
3:22:00 AM: - /opt/build/repo/node_modules/webpack/lib/NormalModuleFactory.js
3:22:00 AM: - /opt/build/repo/node_modules/webpack/lib/Compiler.js
3:22:00 AM: - /opt/build/repo/node_modules/webpack/lib/webpack.js
3:22:00 AM: - /opt/build/repo/node_modules/gatsby/dist/commands/build-html.js
3:22:00 AM: - /opt/build/repo/node_modules/gatsby/dist/commands/build.js
3:22:00 AM: - /opt/build/repo/node_modules/gatsby/node_modules/gatsby-cli/lib/create-cli.js
3:22:00 AM: - /opt/build/repo/node_modules/gatsby/node_modules/gatsby-cli/lib/index.js
3:22:00 AM: - /opt/build/repo/node_modules/gatsby/dist/bin/gatsby.js
3:22:00 AM: not finished run queries - 3.230s
3:22:00 AM: not finished Generating image thumbnails - 3.193s
3:22:01 AM: ​
3:22:01 AM: ┌─────────────────────────────┐
3:22:01 AM: │   "build.command" failed    │
3:22:01 AM: └─────────────────────────────┘
3:22:01 AM: ​
3:22:01 AM:   Error message
3:22:01 AM:   Command failed with exit code 1: gatsby build
3:22:01 AM: ​
3:22:01 AM:   Error location
3:22:01 AM:   In Build command from settings:
3:22:01 AM:   gatsby build
3:22:01 AM: ​
3:22:01 AM:   Resolved config
3:22:01 AM:   build:
3:22:01 AM:     command: gatsby build
3:22:01 AM:     publish: /opt/build/repo/public
3:22:01 AM: Caching artifacts
3:22:01 AM: Started saving node modules
3:22:01 AM: Finished saving node modules
3:22:01 AM: Started saving build plugins
3:22:01 AM: Finished saving build plugins
3:22:01 AM: Started saving pip cache
3:22:08 AM: Finished saving pip cache
3:22:08 AM: Started saving emacs cask dependencies
3:22:08 AM: Finished saving emacs cask dependencies
3:22:08 AM: Started saving maven dependencies
3:22:08 AM: Finished saving maven dependencies
3:22:08 AM: Started saving boot dependencies
3:22:08 AM: Finished saving boot dependencies
3:22:08 AM: Started saving go dependencies
3:22:08 AM: Finished saving go dependencies
3:22:11 AM: Error running command: Build script returned non-zero exit code: 1
3:22:11 AM: Failing build: Failed to build site
3:22:11 AM: Failed during stage 'building site': Build script returned non-zero exit code: 1
3:22:11 AM: Finished processing build request in 2m23.031492714s

What is really weird is that we have the exact same structure on a different site and it works just fine. If we clone and add a new one, this happens. I can’t get it to work ever since.

Sounds like maybe a version problem? Different netlify sites created at different times have different default versions of node, npm, yarn, etc.

Have you specified all of those precisely to match your local, as described here?

If not, would be good to have you run through this build debugging guide and let us know how local testing and any attempts at change have gone:

Thanks for getting back to me, fool.

The only thing I see that’s different when I run npm version is the following:

Netlify:
node: 12.18.0

Local: 12.16.3

But it’s the same on the other instances where everything is working just fine. Also, I am not sure if I am doing this right as I was checking this buy running the command npm version through build command at Settings > Deploy > Build command. Not sure if that’s the right approach either as I have no other options.

Dependencies used (please note this is a starter theme)

{
	"name": "gatsby-starter-default",
	"private": true,
	"description": "A simple starter to get up and developing quickly with Gatsby",
	"version": "1.0.0",
	"author": "Kyle Mathews <mathews.kyle@gmail.com>",
	"dependencies": {
		"@glidejs/glide": "^3.4.1",
		"axios": "^0.19.2",
		"dotenv": "^8.2.0",
		"gatsby": "^2.19.32",
		"gatsby-awesome-pagination": "^0.3.5",
		"gatsby-image": "^2.2.43",
		"gatsby-plugin-facebook-pixel": "^1.0.3",
		"gatsby-plugin-google-analytics": "^2.3.0",
		"gatsby-plugin-load-script": "^1.0.6",
		"gatsby-plugin-manifest": "^2.2.44",
		"gatsby-plugin-netlify": "^2.1.34",
		"gatsby-plugin-offline": "^3.0.32",
		"gatsby-plugin-purgecss": "^4.0.1",
		"gatsby-plugin-react-helmet": "^3.1.21",
		"gatsby-plugin-sass": "^2.1.28",
		"gatsby-plugin-sharp": "^2.4.3",
		"gatsby-source-filesystem": "^2.1.46",
		"gatsby-source-wordpress": "^3.1.62",
		"gatsby-transformer-sharp": "^2.3.17",
		"jquery": "^3.4.1",
		"lodash": "^4.17.15",
		"nanoid": "^2.1.11",
		"node-sass": "^4.13.1",
		"oauth-signature": "^1.5.0",
		"prop-types": "^15.7.2",
		"react": "^16.12.0",
		"react-dom": "^16.12.0",
		"react-helmet": "^5.2.1",
		"react-load-script": "0.0.6",
		"react-magnific-popup": "^1.0.1",
		"react-slick": "^0.25.2",
		"reactjs-popup": "^1.5.0",
		"scroll-into-view": "^1.14.2",
		"slick-carousel": "^1.8.1"
	},
	"devDependencies": {
		"babel-eslint": "^9.0.0",
		"eslint": "^5.16.0",
		"eslint-config-airbnb": "^17.1.1",
		"eslint-config-prettier": "^4.3.0",
		"eslint-config-wesbos": "0.0.19",
		"eslint-plugin-html": "^5.0.5",
		"eslint-plugin-import": "^2.20.1",
		"eslint-plugin-jsx-a11y": "^6.2.3",
		"eslint-plugin-prettier": "^3.1.2",
		"eslint-plugin-react": "^7.18.3",
		"eslint-plugin-react-hooks": "^1.7.0",
		"prettier": "^1.19.1"
	},
	"keywords": [
		"gatsby"
	],
	"license": "MIT",
	"scripts": {
		"build": "gatsby build",
		"develop": "gatsby develop",
		"format": "prettier --write \"**/*.{js,jsx,json,md}\"",
		"start": "npm run develop",
		"serve": "gatsby serve",
		"clean": "gatsby clean",
		"test": "echo \"Write tests! -> https://gatsby.dev/unit-testing\" && exit 1"
	},
	"repository": {
		"type": "git",
		"url": "https://github.com/gatsbyjs/gatsby-starter-default"
	},
	"bugs": {
		"url": "https://github.com/gatsbyjs/gatsby/issues"
	}
}

hey there, would you try making the node version match and see if this fixes your problem?

1 Like

This was one of the first things I tried based on the first reply and it didn’t work. I tried it again and it went through. No idea why but it worked, I set the NODE_VERSION to match mine.

2 Likes

Same issue! This worked for me as well. No idea what caused it because it deployed correctly for months prior.