Failed attempt to renew your TLS certification - Netlify domain

I received an email stating my TLS certificate failed to renew

SniCertificate::CertificateInvalidError: Unable to verify challenge

and I should attempt it manually but there is no option when I go to the settings (it just shows the same error). The guide suggests I should setup the DNS records properly but they haven’t changed from the initial certificate creation which definitely worked and it is a domain provided by Netlify.

Unsure how to proceed.


Logged in today and there was the button for manual renewal and it worked. No longer a problem.

@mpt, we also start trying to renew a week in advance “just in case” (my words). This give us time to troubleshoot if there are errors renewing and before the certificate expires.

In most cases (like this one), the issue does resolve automatically with the next automated attempt or with a manual renewal. However, if the next renewal does not succeed we are always happy to troubleshoot to find out why and help get it working.