Error with netlify.toml

Hello can someone help, I was trying to add an author page to my website then got this message. And whenever I try to make any addition to my website or create a new Netlify site with the same github repository I get this message? What does it mean and how do I fix it?

Hi @acroke

Unfortunately the screenshot does not provide all the details above the error. Important details are in the section preceding that in the screenshot.

Can you share the link to the deploy log and link to the repository you are deploying.

https://app.netlify.com/sites/tender-lamarr-d00871/deploys/61f8048b73c1a40007b12e02

Here is the deploy log and below is the repository

This line stands out

error calling Parse: parse " https://www.linkedin.com/in/tim-jamison-41a55a4/": first path segment in URL cannot contain colon

In most files there appears

link: https://www.linkedin.com/in/tim-jamison-41a55a4/

however in two files this is

link: " https://www.linkedin.com/in/tim-jamison-41a55a4/"

which is what is shown in the error. These are malformed due to the space and/or " wrapping.

Hello,

Thank you the issue has been resolved!

Great to hear it is resolved now @acroke.

Was the issue that which I identified or something else (please specify)?

1 Like

I thought the issue was the env Variable $URL wasn’t set, but maybe I’m mistaken.

If I run hugo --gc --minify -b, I get the 255 error.

1 Like

Ahh yes @talves.

My head is the nail and you just hit it! :rofl:

1 Like

Yeah, for others, you don’t need to set the -b flag on the hugo build if you set it up in the config.toml.

My recommendation is to do that and set it to / in most cases. Make sure to test.

2 Likes