Error fetching branch after trying to update submodule

I need advice to debug deploy https://app.netlify.com/sites/gallant-kirch-586987/deploys/5dd69f2401bc1900080e9b40

Hi there,

I updated a theme which I added as a submodule and I am getting an error with preparing the repo. I am deploying this website using Hugo. my original intention was to change the footer on the sub module but I seem to have broken something. Of course, I still want to update the footer but, I mostly want to get my site back into a working state.

I believe its an issue with the submodule, I tried, reverting the commit, git pulling the submodule and updating it but I’ve had no success.

I appreciate any help you can give me! Thank you in advanced.

9:28:52 AM: Build ready to start
9:28:58 AM: build-image version: 9e0f207a27642d0115b1ca97cd5e8cebbe492f63
9:28:58 AM: build-image tag: v3.3.2
9:28:58 AM: buildbot version: a2bab682ae0761baa4d123ebd00c57be933655dc
9:28:58 AM: Fetching cached dependencies
9:28:58 AM: Starting to download cache of 104.3MB
9:28:59 AM: Finished downloading cache in 678.668723ms
9:28:59 AM: Starting to extract cache
9:29:02 AM: Finished extracting cache in 3.217181833s
9:29:02 AM: Finished fetching cache in 3.951399079s
9:29:02 AM: Starting to prepare the repo for build
9:29:02 AM: Preparing Git Reference refs/heads/master
9:29:04 AM: Error fetching branch: https://x-access-token:v1.107e39111d510ef55b21e27c52e5db6e28b0312a@github.com/etseng02/portfolio refs/heads/master
9:29:04 AM: Failing build: Failed to prepare repo
9:29:04 AM: failed during stage ‘preparing repo’: exit status 1
9:29:04 AM: Finished processing build request in 6.084695546s

1 Like

Solved. It turns out that the cache was pointing to the wrong commit. Cleared cache on netlify before deploying solved the issue.

3 Likes

Thank you for posting the solution!

In case you don’t know how to clear cache and deploy. Go to your deploys page, top right find the button trigger deploys and click clear cache and deploy site.

deploys page -> trigger deploy -> clear cache and deploy site

I’m having the same problem, but my submodule edits aren’t found on github. Did you have to fork the themes repository to get it to work?