Error cloning repository - Failed during stage 'preparing repo': exit status 128

Hi there,

My site name : aesthetic-youtiao-4a01f5

I’m trying to deploy a Next.js website from a cloned Github repository but it keeps failing with error 128.

6:30:23 PM: Build ready to start
6:30:51 PM: build-image version: 9289b698a503f132b265bd089ab40ce1d6f9e65e (focal)
6:30:51 PM: build-image tag: v4.12.0
6:30:51 PM: buildbot version: 8004afba0d79c2913deefb1ea0ee8f3ed710b828
6:30:51 PM: Fetching cached dependencies
6:30:51 PM: Failed to fetch cache, continuing with build
6:30:51 PM: Starting to prepare the repo for build
6:30:51 PM: No cached dependencies found. Cloning fresh repo
6:30:51 PM: git clone
6:30:52 PM: Error cloning repository:
6:30:52 PM: Creating deploy upload records
6:30:52 PM: Failing build: Failed to prepare repo
6:30:52 PM: Failed during stage 'preparing repo': exit status 128
6:30:52 PM: Finished processing build request in 1.530173567s

I wanted to see how moving my website would work (I’m quite the noob) ,so I created a fresh Netlify account , linked it to a repo from a fresh Github account that is the clone of one my repo containing a site that I successfully deployed on Netlify.

I thought this would be a formality but it appears a bit more complicated than I planned.

Following the common troubleshoots, I tried to unlink my repo then link it again but that didn’t change anything.
I also read something about Git-LFS, that the linked repo should be using since the original one did. This is a bit foggy for me, all I know is both repo look identical, and when I browse them I can view the images on both.

I have no other idea, but again, I’m a newbie :smile:

Some update : I unlinked the Github repo and tried a manual deploy by uploading the .next folder created by the (successful) build command, and now I’m stuck even before the deployment begins :

3:15:51 PM: Queueing build

It’s like that since yesterday.
Can someone tell me what’s going on ? It’s certainly quite simple but I don’t see what I did wrong.

Ok that was some remnants assets images with Git LFS that caused it. I deleted it and replaced it with standard files and that worked. I still don’t know why that blocked deployment, I had very little info to work with.

Thanks for coming back and sharing your solution! We are glad you are unblocked now. Happy building :rocket: