2 Deployments Failed during stage 'preparing repo': exit status 128

I am new to Netlify and am trying to deploy a few sites for my work. The sites are currently deployed on an old coworkers Netlify account so I know that they are ready to be deployed. I have ownership to the Github account and need get them set-up on our business account. Thanks in advance to anyone who can help me out. There just is not very much information on the failed to trouble shoot from. I know Netlify takes care of a lot of things “in the ark” so to speak.

netlify site name: tapestry-cerberus.netlify.app

10:22:58 AM: Build ready to start
10:23:00 AM: build-image version: ca811f47d4c1cbd1812d1eb6ecb0c977e86d1a1d
10:23:00 AM: build-image tag: v3.3.20
10:23:00 AM: buildbot version: be8ecf2af866e16fa4301cc5c14de2ccbbb21cf4
10:23:00 AM: Fetching cached dependencies
10:23:01 AM: Failed to fetch cache, continuing with build
10:23:01 AM: Starting to prepare the repo for build
10:23:01 AM: No cached dependencies found. Cloning fresh repo
10:23:01 AM: git clone https://github.com/Cerberus-Agency/tapestry-eleventy
10:23:04 AM: Error cloning repository: https://github.com/Cerberus-Agency/tapestry-eleventy
10:23:04 AM: Failing build: Failed to prepare repo
10:23:04 AM: Failed during stage ‘preparing repo’: exit status 128
10:23:04 AM: Finished processing build request in 3.298726479s

netlify site name: mid-south-coatings.netlify.app

10:42:30 AM: Build ready to start
10:42:34 AM: build-image version: ca811f47d4c1cbd1812d1eb6ecb0c977e86d1a1d
10:42:34 AM: build-image tag: v3.3.20
10:42:34 AM: buildbot version: be8ecf2af866e16fa4301cc5c14de2ccbbb21cf4
10:42:35 AM: Fetching cached dependencies
10:42:35 AM: Failed to fetch cache, continuing with build
10:42:35 AM: Starting to prepare the repo for build
10:42:35 AM: No cached dependencies found. Cloning fresh repo
10:42:35 AM: git clone https://github.com/Cerberus-Agency/midsouthcoatings
10:42:36 AM: Error cloning repository: https://github.com/Cerberus-Agency/midsouthcoatings
10:42:36 AM: Failing build: Failed to prepare repo
10:42:36 AM: Failed during stage ‘preparing repo’: exit status 128
10:42:36 AM: Finished processing build request in 1.98334004s

hey @taylormeyer237,

welcome to netlify.

So the error you are seeing here on both counts basically points towards us having problems connecting to git and pulling those repos so we can start the build process.

If i were you, I’d start here: log in to netlify, and revoke netlify access, and then re-authorize it again to see if that fixes the problem.

If not, give us another shout here and we’ll do some more digging.

1 Like

Hey @perry,

So I did as you suggested with no luck.

Both are currently deployed on my old partners personal team so I am not sure why there is a disconnect between the same repo.

Owner: David Rhoden’s team
API ID: 88860807-9d28-4f55-b0fd-f6b9160255ae
Created: Mar 24 at 6:51 PM
Last update: Jul 19 at 7:17 PM
Owner: David Rhoden’s team
API ID: 99828e0a-daab-4875-873f-c78262e8b3a9
Created: Apr 17 at 10:25 AM
Last update: Jul 16 at 3:54 PM

are you able to do a fresh, git clone --bare of both repos into a new empty local folder without problems?

Yes, I was able to clone --bare for both repos

ok, do me a favour and try this - make a new netlify site from scratch with like - an index.html “hello world” type file and try to deploy that. I wonder if it is something about your config that our service doesn’t like so lets test the connection between your github and netlify with something super simple. will you try that and see if its successful?

1 Like

I can do that, but i have gotten 2 other things deployed while we have been talking through this process, so I don’t know if that changes your thought process.



ok. well that’s good news. So something about your current configuration for those two repos seems like it is not working well with our setup. Do you have the repos public for anything where the deploy worked?

I am sorry I am not following. Do I have the repos public on Github? Is that what you are asking?

the Github is https://github.com/Cerberus-Agency

and yes they are both public there

any more wisdom you might be able to pass down? I have been unsuccessful to this point

I believe my issue is coming from the location of my index.html file.
It is not stored in my root.
index.html is in the admin file, which is in the root.

I tried moving the index.html into the root of the file path and dragging the folder for my site into the manual deployment. It does deploy but because i have a config.yml file in the same folder it messes up my configuration. Is there any way for me to fix this issue?

It looks like you deleted your netlify site. Could you provide a link of a deploy that failed like you mentioned in your original post? I want to take a look at our logs to see exactly why it failed since the error that you mentioned only said “Failed to prepare repo” which can be due to a couple of reasons.

I was surprised Netlify kind of let this go, but I see you have a new reply from them which may explain.

I had a look at your sites, and think the following:

  • you actually have definitions in GitHub which build a site using Eleventy
  • that’s why you don’t see an index.html at root
  • but Eleventy should build an index.html when run, based on the Readme.md
  • you need to understand what this about, not just ‘inherit’ the site. Eleventy is static site builder.
  • given you seem to see the Netlify cloud build not happen correctly, you need to troubleshoot.
  • while it’s possible to do this in the cloud, examining what is really built out there by downloading it (or discovering from the available build log from Netlify), likely it’s lot easier to work this out on the laptop.
  • it looks like your package.json is already set up to build there. In the directory, you’d run eleventy by entering that on your terminal there, and hitting return. This should build the actual site, and you should find index.html now in the root folder, given it succeeds.Opening that index.html should run the intended site.
  • now, your netlify.toml describes running eleventy like this - on Netlfiy to build your site before it appears. So if the site builds on your PC, it should build on Netlify, and work.If it doesn’t work locally, it won’t on Netlify either.
  • one thing you might do in any case is run npm update on the site before trying to build it or deploy to Netlify. It may be that eleventy itself is out of date, for example, and possibly getting current will enable that or any other of the component needed to work as it did for the original owner.

Ok, that’s a bit of a path for advancing on this. If it doesn’t make sense to you, there’s a need then to get help locally. If it does make sense, and you get the site to build locally but it still doesn’t on Netlify, they will need to help you, which I think has just been offered.

Good fortune on this, other than I don’t know why one of the repos talks about honeypots, so I hope it’s legitimate.