Error building with peer dependencies/node/gatsby

Hello,

For the site aerial-access-new.netlify.app I am having some building errors, I think it has to do something with the peer dependencies and that these are clashing with wrong versions, I couldn’t resolve it by my own.

    1:59:32 PM: Build ready to start
1:59:34 PM: build-image version: 7b53c5fc4445e3ec99d3949e5d1174a8c5be4f16
1:59:34 PM: build-image tag: v3.7.2
1:59:34 PM: buildbot version: a8df6d1263bb5bcc16f7b4ebb8e9a6cb904cfa8a
1:59:34 PM: Fetching cached dependencies
1:59:35 PM: Starting to download cache of 227.2MB
1:59:36 PM: Finished downloading cache in 1.838585209s
1:59:36 PM: Starting to extract cache
1:59:44 PM: Finished extracting cache in 8.040246365s
1:59:44 PM: Finished fetching cache in 9.929391711s
1:59:44 PM: Starting to prepare the repo for build
1:59:45 PM: Preparing Git Reference refs/heads/main
1:59:47 PM: Parsing package.json dependencies
1:59:48 PM: Different publish path detected, going to use the one specified in the Netlify configuration file: 'public' versus 'public/' in the Netlify UI
1:59:48 PM: Starting build script
1:59:48 PM: Installing dependencies
1:59:48 PM: Python version set to 2.7
1:59:49 PM: Started restoring cached node version
1:59:51 PM: Finished restoring cached node version
1:59:52 PM: v12.18.0 is already installed.
1:59:53 PM: Now using node v12.18.0 (npm v6.14.4)
1:59:53 PM: Started restoring cached build plugins
1:59:53 PM: Finished restoring cached build plugins
1:59:53 PM: Attempting ruby version 2.7.1, read from environment
1:59:54 PM: Using ruby version 2.7.1
1:59:55 PM: Using PHP version 5.6
1:59:55 PM: Started restoring cached node modules
1:59:55 PM: Finished restoring cached node modules
1:59:55 PM: Installing NPM modules using NPM version 6.14.4
2:00:27 PM: npm WARN read-shrinkwrap This version of npm is compatible with lockfileVersion@1, but package-lock.json was generated for lockfileVersion@2. I'll try to do my best with it!
npm WARN rm not removing /opt/build/repo/node_modules/.bin/detect as it wasn't installed by /opt/build/repo/node_modules/detect-port-alt
npm WARN rm not removing /opt/build/repo/node_modules/.bin/detect-port as it wasn't installed by /opt/build/repo/node_modules/detect-port-alt
2:00:27 PM: > sharp@0.28.1 install /opt/build/repo/node_modules/gatsby-plugin-sharp/node_modules/sharp
2:00:27 PM: > (node install/libvips && node install/dll-copy && prebuild-install) || (node-gyp rebuild && node install/dll-copy)
2:00:29 PM: sharp: Downloading https://github.com/lovell/sharp-libvips/releases/download/v8.10.6/libvips-8.10.6-linux-x64.tar.br
2:00:30 PM: > sharp@0.28.1 install /opt/build/repo/node_modules/gatsby-remark-images-contentful/node_modules/sharp
2:00:30 PM: > (node install/libvips && node install/dll-copy && prebuild-install) || (node-gyp rebuild && node install/dll-copy)
2:00:31 PM: sharp: Using cached /opt/buildhome/.npm/_libvips/libvips-8.10.6-linux-x64.tar.br
2:00:32 PM: > core-js@3.11.0 postinstall /opt/build/repo/node_modules/core-js
2:00:32 PM: > node -e "try{require('./postinstall')}catch(e){}"
2:00:33 PM: > gatsby-telemetry@2.3.0 postinstall /opt/build/repo/node_modules/gatsby-telemetry
2:00:33 PM: > node src/postinstall.js || true
2:00:33 PM: > gatsby-cli@3.3.0 postinstall /opt/build/repo/node_modules/gatsby-cli
2:00:33 PM: > node scripts/postinstall.js
2:00:33 PM: > gatsby@3.3.1 postinstall /opt/build/repo/node_modules/gatsby
2:00:33 PM: > node scripts/postinstall.js
2:00:35 PM: npm WARN express-graphql@0.9.0 requires a peer of graphql@^14.4.1 but none is installed. You must install peer dependencies yourself.
2:00:35 PM: npm WARN gatsby-plugin-sass@3.1.0 requires a peer of gatsby@^2.0.0 but none is installed. You must install peer dependencies yourself.
2:00:35 PM: npm WARN gatsby-source-filesystem@2.11.1 requires a peer of gatsby@^2.2.0 but none is installed. You must install peer dependencies yourself.
2:00:35 PM: npm WARN gatsby-transformer-sharp@2.12.1 requires a peer of gatsby@^2.12.1 but none is installed. You must install peer dependencies yourself.
2:00:35 PM: npm WARN gatsby-transformer-sharp@2.12.1 requires a peer of gatsby-plugin-sharp@^2.0.0-beta.3 but none is installed. You must install peer dependencies yourself.
2:00:35 PM: npm WARN ts-node@9.1.1 requires a peer of typescript@>=2.7 but none is installed. You must install peer dependencies yourself.
2:00:35 PM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules/webpack-dev-server/node_modules/fsevents):
2:00:35 PM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
2:00:35 PM: npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.3.1 (node_modules/fsevents):
2:00:35 PM: npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.3.1: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
2:00:35 PM: added 618 packages from 231 contributors, removed 378 packages, updated 271 packages and audited 2769 packages in 39.479s
2:00:37 PM: 278 packages are looking for funding
2:00:37 PM:   run `npm fund` for details
2:00:37 PM: found 0 vulnerabilities
2:00:37 PM: NPM modules installed
2:00:38 PM: Started restoring cached go cache
2:00:38 PM: Finished restoring cached go cache
2:00:38 PM: go version go1.14.4 linux/amd64
2:00:38 PM: go version go1.14.4 linux/amd64
2:00:38 PM: Installing missing commands
2:00:38 PM: Verify run directory
2:00:39 PM: ​
2:00:39 PM: ────────────────────────────────────────────────────────────────
2:00:39 PM:   Netlify Build                                                 
2:00:39 PM: ────────────────────────────────────────────────────────────────
2:00:39 PM: ​
2:00:39 PM: ❯ Version
2:00:39 PM:   @netlify/build 11.3.2
2:00:39 PM: ​
2:00:39 PM: ❯ Flags
2:00:39 PM:   deployId: 608a9fa4eaa0850007d4c310
2:00:39 PM: ​
2:00:39 PM: ❯ Current directory
2:00:39 PM:   /opt/build/repo
2:00:39 PM: ​
2:00:39 PM: ❯ Config file
2:00:39 PM:   No config file was defined: using default values.
2:00:39 PM: ​
2:00:39 PM: ❯ Context
2:00:39 PM:   production
2:00:39 PM: ​
2:00:39 PM: ────────────────────────────────────────────────────────────────
2:00:39 PM:   1. Build command from Netlify app                             
2:00:39 PM: ────────────────────────────────────────────────────────────────
2:00:39 PM: ​
2:00:39 PM: $ gatsby build
2:00:43 PM: success open and validate gatsby-configs - 0.047s
2:00:43 PM: warning Plugin gatsby-plugin-sass is not compatible with your gatsby version 3.3.1 - It requires gatsby@^2.0.0
2:00:43 PM: warning Plugin gatsby-transformer-sharp is not compatible with your gatsby version 3.3.1 - It requires gatsby@^2.12.1
2:00:43 PM: warning Plugin gatsby-source-filesystem is not compatible with your gatsby version 3.3.1 - It requires gatsby@^2.2.0
2:00:43 PM: warning Plugin gatsby-source-filesystem is not compatible with your gatsby version 3.3.1 - It requires gatsby@^2.2.0
2:00:44 PM: warning Warning: there are unknown plugin options for "gatsby-source-filesystem": prettier, eslint, typekit
2:00:44 PM: Please open an issue at ghub.io/gatsby-source-filesystem if you believe this option is valid.
2:00:44 PM: warning Plugin gatsby-plugin-sass is not compatible with your gatsby version 3.3.1 - It requires gatsby@^2.0.0
2:00:44 PM: warning Plugin gatsby-transformer-sharp is not compatible with your gatsby version 3.3.1 - It requires gatsby@^2.12.1
2:00:44 PM: warning Plugin gatsby-source-filesystem is not compatible with your gatsby version 3.3.1 - It requires gatsby@^2.2.0
2:00:44 PM: warning Plugin gatsby-source-filesystem is not compatible with your gatsby version 3.3.1 - It requires gatsby@^2.2.0
2:00:44 PM: success load plugins - 1.194s
2:00:44 PM: success onPreInit - 0.048s
2:00:44 PM: success initialize cache - 0.006s
2:00:44 PM: success copy gatsby files - 0.070s
2:00:44 PM: success onPreBootstrap - 0.020s
2:00:44 PM: success createSchemaCustomization - 0.132s
2:00:45 PM: success Contentful: Sync all items - 0.061s - 42/1000 16407.98/s
2:00:45 PM: success Contentful: Fetch data (8cxl6mpst1xl-master) - 0.241s
2:00:45 PM: info Updated entries 15
2:00:45 PM: info Deleted entries 0
2:00:45 PM: info Updated assets 27
2:00:45 PM: info Deleted assets 0
2:00:45 PM: success Contentful: Process data (8cxl6mpst1xl-master) - 0.035s
2:00:45 PM: info Creating 4 Contentful Project nodes
2:00:45 PM: info Creating 4 Contentful ProductCategory nodes
2:00:45 PM: info Creating 7 Contentful Product nodes
2:00:45 PM: info Creating 27 Contentful asset nodes
2:00:45 PM: success Contentful: Create nodes (8cxl6mpst1xl-master) - 0.049s
2:00:45 PM: success Checking for changed pages - 0.000s
2:00:45 PM: success source and transform nodes - 1.002s
2:00:46 PM: error "gatsby-source-contentful" threw an error while running the setFieldsOnGraphQLNodeType lifecycle:
2:00:46 PM: Cannot find module 'gatsby-plugin-image/graphql-utils'
2:00:46 PM: Require stack:
2:00:46 PM: - /opt/build/repo/node_modules/gatsby-source-contentful/extend-node-type.js
2:00:46 PM: - /opt/build/repo/node_modules/gatsby-source-contentful/gatsby-node.js
2:00:46 PM: - /opt/build/repo/node_modules/gatsby/dist/bootstrap/load-plugins/validate.js
2:00:46 PM: - /opt/build/repo/node_modules/gatsby/dist/bootstrap/load-plugins/load.js
2:00:46 PM: - /opt/build/repo/node_modules/gatsby/dist/bootstrap/load-plugins/index.js
2:00:46 PM: - /opt/build/repo/node_modules/gatsby/dist/services/initialize.js
2:00:46 PM: - /opt/build/repo/node_modules/gatsby/dist/services/index.js
2:00:46 PM: - /opt/build/repo/node_modules/gatsby/dist/bootstrap/index.js
2:00:46 PM: - /opt/build/repo/node_modules/gatsby/dist/commands/build.js
2:00:46 PM: - /opt/build/repo/node_modules/gatsby-cli/lib/create-cli.js
2:00:46 PM: - /opt/build/repo/node_modules/gatsby-cli/lib/index.js
2:00:46 PM: - /opt/build/repo/node_modules/gatsby/dist/bin/gatsby.js
2:00:46 PM: - /opt/build/repo/node_modules/gatsby/cli.js
2:00:46 PM: 
2:00:46 PM: 
2:00:46 PM:   Error: Cannot find module 'gatsby-plugin-image/graphql-utils'
2:00:46 PM:   Require stack:
2:00:46 PM:   - /opt/build/repo/node_modules/gatsby-source-contentful/extend-node-type.js
2:00:46 PM:   - /opt/build/repo/node_modules/gatsby-source-contentful/gatsby-node.js
2:00:46 PM:   - /opt/build/repo/node_modules/gatsby/dist/bootstrap/load-plugins/validate.js
2:00:46 PM:   - /opt/build/repo/node_modules/gatsby/dist/bootstrap/load-plugins/load.js
2:00:46 PM:   - /opt/build/repo/node_modules/gatsby/dist/bootstrap/load-plugins/index.js
2:00:46 PM:   - /opt/build/repo/node_modules/gatsby/dist/services/initialize.js
2:00:46 PM:   - /opt/build/repo/node_modules/gatsby/dist/services/index.js
2:00:46 PM:   - /opt/build/repo/node_modules/gatsby/dist/bootstrap/index.js
2:00:46 PM:   - /opt/build/repo/node_modules/gatsby/dist/commands/build.js
2:00:46 PM:   - /opt/build/repo/node_modules/gatsby-cli/lib/create-cli.js
2:00:46 PM:   - /opt/build/repo/node_modules/gatsby-cli/lib/index.js
2:00:46 PM:   - /opt/build/repo/node_modules/gatsby/dist/bin/gatsby.js
2:00:46 PM:   - /opt/build/repo/node_modules/gatsby/cli.js
2:00:46 PM:   
2:00:46 PM:   - loader.js:966 Function.Module._resolveFilename
2:00:46 PM:     internal/modules/cjs/loader.js:966:15
2:00:46 PM:   
2:00:46 PM:   - loader.js:842 Function.Module._load
2:00:46 PM:     internal/modules/cjs/loader.js:842:27
2:00:46 PM:   
2:00:46 PM:   - loader.js:1026 Module.require
2:00:46 PM:     internal/modules/cjs/loader.js:1026:19
2:00:46 PM:   
2:00:46 PM:   - v8-compile-cache.js:159 require
2:00:46 PM:     [repo]/[v8-compile-cache]/v8-compile-cache.js:159:20
2:00:46 PM:   
2:00:46 PM:   - extend-node-type.js:817 getGatsbyImageData
2:00:46 PM:     [repo]/[gatsby-source-contentful]/extend-node-type.js:817:9
2:00:46 PM:   
2:00:46 PM:   - extend-node-type.js:873 Object.exports.extendNodeType [as setFieldsOnGraphQL    NodeType]
2:00:46 PM:     [repo]/[gatsby-source-contentful]/extend-node-type.js:873:22
2:00:46 PM:   
2:00:46 PM:   - api-runner-node.js:434 runAPI
2:00:46 PM:     [repo]/[gatsby]/src/utils/api-runner-node.js:434:22
2:00:46 PM:   
2:00:46 PM:   - api-runner-node.js:585 Promise.catch.decorateEvent.pluginName
2:00:46 PM:     [repo]/[gatsby]/src/utils/api-runner-node.js:585:13
2:00:46 PM:   
2:00:46 PM:   - debuggability.js:384 Promise._execute
2:00:46 PM:     [repo]/[bluebird]/js/release/debuggability.js:384:9
2:00:46 PM:   
2:00:46 PM:   - promise.js:518 Promise._resolveFromExecutor
2:00:46 PM:     [repo]/[bluebird]/js/release/promise.js:518:18
2:00:46 PM:   
2:00:46 PM:   - promise.js:103 new Promise
2:00:46 PM:     [repo]/[bluebird]/js/release/promise.js:103:10
2:00:46 PM:   
2:00:46 PM:   - api-runner-node.js:583 
2:00:46 PM:     [repo]/[gatsby]/src/utils/api-runner-node.js:583:16
2:00:46 PM:   
2:00:46 PM:   - util.js:16 tryCatcher
2:00:46 PM:     [repo]/[bluebird]/js/release/util.js:16:23
2:00:46 PM:   
2:00:46 PM:   - reduce.js:166 Object.gotValue
2:00:46 PM:     [repo]/[bluebird]/js/release/reduce.js:166:18
2:00:46 PM:   
2:00:46 PM:   - reduce.js:155 Object.gotAccum
2:00:46 PM:     [repo]/[bluebird]/js/release/reduce.js:155:25
2:00:46 PM:   
2:00:46 PM:   - util.js:16 Object.tryCatcher
2:00:46 PM:     [repo]/[bluebird]/js/release/util.js:16:23
2:00:46 PM:   
2:00:46 PM: 
2:00:46 PM: not finished building schema - 0.449s
2:00:46 PM: ​
2:00:46 PM: ────────────────────────────────────────────────────────────────
2:00:46 PM:   "build.command" failed                                        
2:00:46 PM: ────────────────────────────────────────────────────────────────
2:00:46 PM: ​
2:00:46 PM:   Error message
2:00:46 PM:   Command failed with exit code 1: gatsby build
2:00:46 PM: ​
2:00:46 PM:   Error location
2:00:46 PM:   In Build command from Netlify app:
2:00:46 PM:   gatsby build
2:00:46 PM: ​
2:00:46 PM:   Resolved config
2:00:46 PM:   build:
2:00:46 PM:     command: gatsby build
2:00:46 PM:     commandOrigin: ui
2:00:46 PM:     environment:
2:00:46 PM:       - CONTACT_EMAIL
2:00:46 PM:       - GATSBY_CONTENTFUL_ACCESS_TOKEN
2:00:46 PM:       - GATSBY_CONTENTFUL_SPACE_ID
2:00:46 PM:     publish: /opt/build/repo/public
2:00:46 PM:   functionsDirectory: /opt/build/repo/netlify/functions
2:00:46 PM: Caching artifacts
2:00:46 PM: Started saving node modules
2:00:46 PM: Finished saving node modules
2:00:46 PM: Started saving build plugins
2:00:46 PM: Finished saving build plugins
2:00:46 PM: Started saving pip cache
2:00:47 PM: Finished saving pip cache
2:00:47 PM: Started saving emacs cask dependencies
2:00:47 PM: Finished saving emacs cask dependencies
2:00:47 PM: Started saving maven dependencies
2:00:47 PM: Finished saving maven dependencies
2:00:47 PM: Started saving boot dependencies
2:00:47 PM: Finished saving boot dependencies
2:00:47 PM: Started saving rust rustup cache
2:00:47 PM: Finished saving rust rustup cache
2:00:47 PM: Started saving go dependencies
2:00:47 PM: Finished saving go dependencies
2:00:47 PM: Build failed due to a user error: Build script returned non-zero exit code: 2
2:00:47 PM: Creating deploy upload records
2:00:47 PM: Failing build: Failed to build site
2:00:47 PM: Failed during stage 'building site': Build script returned non-zero exit code: 2
2:00:47 PM: Finished processing build request in 1m12.713797094s

I hope you guys could help me out with this, appreciate it. Thanks in advance!

What are the steps to resolve this build bug?

Do you have this module in your package.json?