Enabling wildcard subdomains

Hi,

My netlify app name is determined-leakey-ea8996 and i have a pro account.

I have been trying to get wildcard subdomain to work for me using a cname record but always get a Not Found - Request ID: **** error.
I stumbled upon this post and see that the admin could enable it for our account.

Can you please help me here.

Thanks,
Aditya

We have not configured the feature for that site, so it is no surprise it doesn’t work.

Did one of our staff say we’d done so? It is a feature that requires us to enable it for you after reviewing your config, not one that “just magically works” :slight_smile:

Regardless, I have now enabled the feature and do see it working. You will of course have to configure DNS records appropriately, but this test (I assigned a CDN node as though you had configured DNS using curl’s --resolve flag), shows your content being served for a “random” hostname:

% curl -v https://asdf.myresto.co.uk --resolve asdf.myresto.co.uk:443:52.52.138.60 -o /dev/null
* Added asdf.myresto.co.uk:443:52.52.138.60 to DNS cache
* Hostname asdf.myresto.co.uk was found in DNS cache

* Server certificate:
*  subject: CN=*.myresto.co.uk
*  start date: Feb  8 17:35:14 2022 GMT
*  expire date: May  9 17:35:13 2022 GMT
*  subjectAltName: host "asdf.myresto.co.uk" matched cert's "*.myresto.co.uk"
*  issuer: C=US; O=Let's Encrypt; CN=R3
*  SSL certificate verify ok.

> GET / HTTP/2
> Host: asdf.myresto.co.uk
> user-agent: curl/7.79.0
> accept: */*
>

< HTTP/2 200
< cache-control: public, max-age=0, must-revalidate
< content-type: text/html; charset=UTF-8
< date: Thu, 10 Feb 2022 20:56:45 GMT
< etag: "6adf4b3064ee7cba8d9d14c1b1978f17-ssl"
< strict-transport-security: max-age=31536000
< content-length: 4352
< age: 25
< server: Netlify