Setting an app with wildcard subdomains

SITE: cue-streaming-signup
PROBLEM: Using wildcard subdomains (at: or bar., can’t access site.

  1. Using Netlify DNS, setup to point to This works.
  2. Also setup * to point to THIS IS THE PROBLEM AREA

I receive a 404 error when going to something like

This is a SvelteKit app using SSR, but I’ve simplified the variables by just making the server side render return simple static info.

export async function load() {
    return {
        affinityId: 'foobar',
        title: 'Foobar Test!!!',
        frontMatter: { title: 'Foobar Test' },
        content: '<h1>Foobar Test</h1>',

So that probably is not a factor. This DOES all work locally. It also works on more traditional hosts like, etc.

Thank you in advance for your help.

As noted in the post below, there are some requirements for wildcard sub-domains. Check you meet them all.

Yep… read that post before I posted. I believe I meet all those criteria. If I don’t then I am certainly not aware of it. I am a PRO customer. The explanation about primary domain being on the same level, etc, is a little unclear… but as you can see from my examples I seem to be meeting that one, as well… I want to work for… and IS the primary domain.

That’s great. Now the last bit states

If that sounds like something that would work, please let us know and we’d enable it for your site.

This means Netlify need to flick a switch to enable this feature. As I don’t work for Netlify I can’t do this. A support engineer can check and enable this as soon as they are able.

Ah… ok… how do I get that to happen? Or will a support engineer respond to this thread?

Yes, they will respond.

@jholmes033169 Great, I’ve enabled wildcard subdomains for you! Please redeploy the site for the change to take effect. Let us know if there’s any issues.