DNS which previously worked on my custom domain now doesn't

I followed the guide on how to setup custom domain from external providers and everything worked as expected. Two months down the line the custom domain does not resolve.
The netlify site name is: makimei-zenjy.netlify.app
Below is the error I’m getting on the [SSL/TLS certificate] section.
makimeichildrenshome.org doesn't appear to be served by Netlify

My Custom domain is makimeichildrenshome.org/. I also did a whois check when following one of your troubleshooting guides to find the name servers for the domain name, this is the screenshot of the response I got.

Kindly advice on what could be the issue.

Hey @zenjutahi

I see the same whois result. I also see the domain is present in Netlify DNS

$ dig makimeichildrenshome.org @dns1.p02.nsone.net +noall +answer

makimeichildrenshome.org. 20	IN	A
makimeichildrenshome.org. 20	IN	A

However, I see no SOA, and no NS (and therefore no A, CNAME, MX, etc records) associated with the domain

$ dig makimeichildrenshome.org SOA +noall +answer

# and

$ dig makimeichildrenshome.org NS +noall +answer

Therefore, there is something amiss with this domain. You may need to contact the Registrar for assitance.

Hello @coelmay
Thank you for the response. I appreciate. So you advice I confirm with the guys I registered my domain with ?

Correct @zenjutahi, I suggest contacting the registrar.

Ping @luke for anything further you could possibly share.

1 Like

Hi, @zenjutahi. It looks like you got it working now:

$ curl --compressed -svo /dev/null https://makimeichildrenshome.org/  2>&1 | egrep '^(<|>) '
> GET / HTTP/2
> Host: makimeichildrenshome.org
> User-Agent: curl/7.64.1
> Accept: */*
> Accept-Encoding: deflate, gzip
< HTTP/2 200
< age: 0
< cache-control: public, max-age=0, must-revalidate
< content-encoding: gzip
< content-type: text/html; charset=UTF-8
< date: Tue, 12 Apr 2022 09:22:39 GMT
< etag: "6b19cca6ba1d997a1c73bd930f46dd5a-ssl-df"
< server: Netlify
< strict-transport-security: max-age=31536000
< vary: Accept-Encoding
< x-nf-request-id: 01G0EHA1VAQSWGVV02E73KFFYS

The SSL certificate has also been renewed now.

If there are other questions or concerns, please let us know.

1 Like

@luke @coelmay , I contacted the register as advised and the sorted it. The issue was on their side.

Thanks for the help.