Deployment from Github fails

We have a small non-profit and the website that was put together several years ago needs to be updated. The coders/web designers that were involved initially are no longer available. While we are looking to engage a new web designer, we are trying to fix the deployment error on our own - with the help of this forum. We have very limited knowledge, so any feedback that is offered is appreciated, especially if it can be provided in step-by-step fashion in layman’s terms.

The site is Within the Netlify log-in, it is just labeled as cc4es-website. The site data is in Github. It appears that there is an issue getting Github and Netlify to properly communicate with the deployment. There is an error on the deployment that refers to a folder that doesn’t exist. It is unclear how that can be resolved. I posted the issue on the Github forum but the answers there suggested coming to the Netlify forum.

I tried to put the full deployment log here but the system limits how much I can add. This is the bottom portion showing the errors.

6:03:18 AM: Configuration error
6:03:18 AM: ────────────────────────────────────────────────────────────────
6:03:18 AM: ​
6:03:18 AM: Error message
6:03:18 AM: Deploy did not succeed: Deploy directory β€˜opt/build/repo/build’ does not exist
6:03:18 AM: ​
6:03:18 AM: Resolved config
6:03:18 AM: build:
6:03:18 AM: command: bundle exec middleman build --verbose
6:03:18 AM: commandOrigin: config
6:03:18 AM: environment:
6:03:18 AM: - CI
6:03:18 AM: publish: /opt/build/repo/opt/build/repo/build
6:03:18 AM: publishOrigin: config

6:03:20 AM: Build failed due to a user error: Build script returned non-zero exit code: 2
6:03:20 AM: Creating deploy upload records
6:03:20 AM: Failing build: Failed to build site
6:03:20 AM: Failed during stage β€˜building site’: Build script returned non-zero exit code: 2 (Search results for '"non-zero exit code: 2"' - Netlify Support Forums)
6:03:20 AM: Finished processing build request in 3m50.934283302s

Hello @dsgorelick, sorry your deployment from Github fails.

  1. First of all does your project contain a netlify.toml file?
  2. What framework was used to build the website? (React, Angular, Vue.js e.t.c)

If possible kindly share a snippet of your netlify.toml file that’s if it exits in your project.


Let me know if the image does not work, here is the netlify.toml file:

I don’t know what is meant by framework as none of the examples you provide are familiar based upon what I see in Github. Here is a snippet of the folders/files on the Github site if that may answer that question:

Based on the build command in your netlify.toml file in the image, it seems your site is using middleman to build the website.

Make a backup of your current netlify.toml file before you make any changes just in case.

For middleman set all the publish values to β€œ/build”
Also set all the command values to β€œmiddleman build”

Alternatively you can visit the link below (scroll to Connecting to Netlify section) on how to host Middleman sites on Netlify using the Netlify Browser UI.
If the problem persists, try to follow the steps from the beginning to see if it helps.

Let me know the outcome when you try the steps above.

Hope this helps.


Brilliant. Took me a bit to figure out how to apply the suggested changes, but I did them and the site updated successfully. Many thanks.

1 Like

Hello @dsgorelick , Glad to know you were able to fix the problem by following the suggested solution.
Kindly mark the suggested solution as solved in order to help others in the future who might also experience a similar problem.


Hiccup this morning. Hopefully the fix is straightforward - but I cannot see what to do.

The only changes I made were (1) data folder - about_us.yml file - I added a team member and shifted others around by simply doing free text, copy/paste within the yml file. I kept all of the same formatting. (2) Source folder - images folder - I uploaded two pictures and used the names of those pictures within the about_us.yml file. (3) source folder β€œabout-us.html.erb” file - I edited two small areas of text without changing any formatting of the file.

I did not change the netlify.toml file or the deploy settings.

Any suggestions?

Hi @dsgorelick, sorry for there has been a hiccup this morning.

Making changes to yml files can be very tricky. The format could be the same but even a space or a tab could cause problems.

At this point it would be appropriate to get a developer to assist you with making the changes in the code.

However if you still insist on making changes kindly visit the middleman documentation for more information.


Very well. Thanks for the guidance.

1 Like

Based upon what you have seen with our site, would you have a reference for a developer?

@dsgorelick The website design depends on what the organization wants. On that note I do not have any reference. However you can get local developers in your area. Or if you prefer remote developers you can get one on websites like Upwork. You can discuss with the Human Resource manager in your organization.


Hi @dsgorelick

I noticed your github repo is public and it turns out there is some formatting issues in your about_us.yml file. Normally we do not debug code if it is not directly related to our services, however I also understand that yaml is a pain to deal with as @clarnx mentioned the following.

Making changes to yml files can be very tricky. The format could be the same but even a space or a tab could cause problems.

I found this site called where you could copy and paste the contents of your about_us.yml file and you will be able to know what is wrong.

Specifically you have an extra space on line 173 for Melissa Guillet and line 241 for Doug Victor

Hope this helps :slight_smile:

1 Like

Slick utility. I plugged the yml in and it showed exactly what you noted. The site has been updated successfully. Thank you.

1 Like