Deploy using rollup -c: rollup is not recognized

Hi, I have the project which uses rollup -c to make builds, and it builds successfully and works good in manual deployment, but when I try to configure site and deploy from netlify giving options rollup -c for build it says rolllup not recognized or found, so help on this please and thank you

@Suprith Rollup isn’t installed by default in the Netlify build image, so you would need to ensure that it’s installed as a dependency of your project.

If you followed the Rollup guide here then you probably installed Rollup globally on your own system.

You should install it so that it ends up specified as a dependency in your package.json, which will ensure it is installed by Netlify when your build runs. You can see some related Rollup documentation here:

I did include rollup as dependency but it fails initializing, in my computer I had to to provide root user permission to install rollup. Is that the reason why…

@Suprith I can’t really advise on how your system is configured.

The error showing in the Netlify build log is a peer dependency error.

Hi, so I was able to build without errors, but because I am using Lit the website is just the first html file.
It never goes inside the shadowRoot.

But i used netlify-cli for continuous integration which was fine until, it works when i run manual command for the pipeline, but it doesnt run from the gitlab itself

saying the folder isnt linked,

I’m sorry, I don’t really understand your questions at this point. You’re unable to get inside shadow root and you’re not able to build on GitLab? None of those seem to be Netlify issues. Could you please clarify with more details?

1st I tried to build directly from netlify “deploy from gitlab” where it does not take lit-elements into consideration itself. It builds only html and css.
So, 2nd i tried netlify-cli I deployed it manually, then I set a ci/cd pipeline where netlify has to build again and again by using the command “netlify deploy --dir “dist” --auth $AUTH_TOKEN --site $SITE_ID_PROD --prod” At this 2nd attempt it should have worked ------------- but this command works when i provide it in from vscode but fails in automatic pipeline

What version of CLI are you using?