Deploy Preview works but not actual production site

Hey, my Netlify site name is: and here is my custom domain

I deployed two new pages. The build is completed successfully. When I am visiting these pages using the deploy preview link i.e. The World is Always Rooting for a New Hero | Fortanix CEO and Co-founder Ambuj Kumar | Midstage Institute It works!

But when I am trying to go through the production domain using i.e. /pov/fortanix-ceo-cofounder-ambuj-kumar-the-world-is-always-rooting-for-a-new-hero It gives me the 404 page.
The same goes with domain as well.

It will be great if you could help me fix this. Thanks!

FYI: I tried to upload the build log txt file. But the editor doesn’t let me. Let me know how can I help if that’s required.

Hi @RolandSibelink

I am able to load this page on your custom domain as well as the preview URL.

Are you sure you don’t get the 404 notice “Sorry we could not find this file”? That’s what I get on my side.

Hi there, @RolandSibelink :wave:

I am not seeing this error when I follow the links either. Does this happen for you across multiple browsers and machines? Can you send us the browser version you are using when you receive this message, or a screenshot of what is happening?


1 Like

Hi there,

here’s a few screenshots from one of my team member:

Browser: Microsoft Edge
We are able to load the page on a normal window but doesn’t work on InPrivate (Incognito)

The webpage doesn’t load on a normal window, but loads on Incognito mode

Same with Edge: We are able to load the page on a normal window but doesn’t work on Private (Incognito)

Chrome on Mobile:

webpage is not loading both on normal or incognito

Hey @RolandSibelink

Got it.

You have split testing enabled (as per nf_ab cookie below) which means that you have likely published this article to one branch and not the other(s).

As you can see the nf_ab cookie is not set to expire for 12 months. That means that anyone who has the cookie set for the branch this article is not published on will not see the article. It took several tries in an private window in Firefox to get the page to load. The last time (which I did not screenshot; should have though) it happened first time round.

@coelmay I published it on master branch.

You’re recommending me to publish it on all the other branches too? I can try that.

I thought production only follows the updates in the master branch only. Please correct me if I am wrong?

By default the main branch of a Netlify site deploys from the main/master branch of GitHub (for instance, but Gitlab/Bitbucket are similar) though you can change this. If you then have a second git branch you can then deploy this as a separate branch and enable split testing. As demonstrated in the Jamstack Explorers Mission Split testing with Netlify this is handy for testing multiple CTAs, colour schemes, or even opt-in betas.

If you are using (for example) content stored as markdown in your main git repository, this does not get deployed to the other branches. Likewise if you are adding new content to the second (or more) branch, this does not get deployed to the main branch.

If you use an external source (e.g. Contentful, Strapi, Sanity) to manage content, then technically all branches would update with the latest content at the same time (assuming they were all triggered to build on content changes or you manually triggered each branch.)

If you want this content visible on all branches, then yes.

Under “Latest Points of View” I see two different things depending on the branch:


I can count several articles listed on the homepage between those two dates which are only published to one branch. Anyone who is getting this branch (which I receive more often than the other in my testing) would think you have posted anything in months.

In both cases, the footer shows:

Screen Shot 2021-10-06 at 10.53.25 am

I don’t know if you have this already (can’t see anything in your source) however you can distinguish branches in analytics for some insights into how many people see each branch.

Hi, @RolandSibelink. I just want to +1 what @coelmay already said. The issue is that the other branch in the split test doesn’t include this file. If the split test sends you to the non-production version, then the 404 occurs.

The solutions for this are to disable the split tests or to add to add the URL to both branches.

Hi Coel and Luke,

Deploying on all our branches seems to have resolved the issue.

Thanks. Appreciate you help.