Sucessfully builds, deploys, and screenshot-previews, but 404's?

hello beautiful humans…

  • i’ve deployed a site on netlfiy that builds sucessfully, deploys successfully, and previews properly (screenshot in netlify dsahboard)


I can see it :thinking:

have you tried on a different network (i.e phone?)

maybe it just needed a minute!

  • oh wow how weird
  • thanks for letting me know @perry :pray:t5:
  • i’ve tried 2 different networks and 3 different devices
  • and it’s been 14hrs since it was first deployed
  • still it’s 404-ing for me

it may have not made it all the way down to :australia: yet. I have a strong feeling it’ll sort itself out in a few hours. if the problem persists in a day or so, ping us again?

  • i appreciate your help @perry
  • i have a today deadline; like 15mins from now
  • so it’s a bit of a nighmare
  • still i :heart: netlify forevs

ugh. could you…use a vpn and pretend to be in the US?

  • am now doing
  • thanks for the tip
  • is now working
  • for me at least
  • (client is same country as me though and not sure of their vpn-ability)
  • either way you’ve totes solve my personal riddle as i now know it’s not a delpoyment or build issue
  • thank you!

interestingly the site …

  • 404’s on my laptop when using no vpn
  • loads on my laptop when using proton vpn
  • 404’s on my phone when using no vpn
  • 404’s on my phone when using cloudflare warp
  • loads on my phone when using proton vpn


i’m still not sure what the problem is. i’ve resolved some of it but it keeps getting weirder…

  • turns out it was only the homepage that was 404-ing for me
  • it 404’s at the root level (
  • but it resloves properly at the file level (
  • i saw some really strange url structure in the analyics for this site which got me to thinking
  • so i changed the “site name” (in netlfiy site settings)
  • odlly changing the site name instantly fixed the problem
  • but if i change the site name back to the original the problem reappears
  • any thoughts @perry?
  • the old site name was “fld” but it’s now using “flddev”

hi there, any changes to this? are you still seeing the issue?

Thanks so much for all your testing! Using it I am pretty sure I know what happened.

However, like you, I cannot reproduce with the new name. Our CDN does indeed cache by name and it seems like there was/is some wrong cache for the old name. If you want to create a NEW site at and deploy the same code there (leaving the old site called ‘flddev’), and let me know, I can both check and repair the caches.

Without a site there, it is impossible for me to do so, though.

  • firsty, thanks so much for your support @perry & @fool
  • netlify is true love
  • yes @perry, the problem persisted
  • and yes @fool, your solution fixed it
  • i just deployed the exact same code + deploy settings, changed the new site name to “fld” and can i see the homepage at the root level of ‘fld’ as expected
  • one thing i often wonder about with new sites is changing the “site name” while an initial build/deply is happening. is that a problem? i know it can be done cause i’ve done it a number of times, even though i’m thinking “this might be a bad idea”… :sweat_smile:
  • nb: interestingly i have another wierd problem with the next site i added to my netfliy after this fld/flddev site issue. it’s a different problem (the build can’t find the publish directory). could this be related?

It’s less about deploy timing (though changing while a build is in progress could have interesting effects, come to think of it - we manage cache a bit by 2 separate keys: site ID and site name) and more about reusing the same names. We don’t drop cache for the OLD name when you rename a site, so that’s what polluted the cache today.

Seems unlikely the other problem around publish directory is related - mind linking to the site or sharing its ID?

  • yes it’s always suprised me you can site-name-change almost-instantly — while initial things still seem to be happening — cause as you know, if we [users] can find a way to break things we will!

If you get the site building locally and it still won’t build at Netlify, please make a new topic here in the community and we’ll be happy to troubleshoot.

Also, would you willing to please let us know the site name or site API ID? You can private message (PM) that information to one of the support team if you prefer.

  • thanks for all your help
  • this seems to be solved for me atm
  • sorry to pester @fool but i’ve got this same problem on another new domain
  • the problem being ‘/index.html’ resolves but the root domain 404’s
  • just wondering if there’s anything i can do without having to create the new site again?
  • the site is
  • thanks
  • problems is fixed now
  • thanks!
1 Like

fantastic. glad we were able to figure it out. greetings to :australia: from us up here in the pacific NW of :us:

1 Like

hope you’re all staying safe as safe can be…

me :hugs:

1 Like